Überblick

TreeSize Professional 3

TreeSize Professional ist ein leistungsfähiger und vielseitiger Manager für den Platz Ihrer Festplatte unter Windows 98/ME/NT/2000/XP. Finden Sie heraus, welche Verzeichnisse den meisten Platz belegen und gewinnen Sie viele Megabytes auf Ihrer Festplatte zurück. TreeSize Professional zeigt ihnen für jedes Verzeichnis dessen Größe, den tatsächlich belegten Platz, den durch das Dateisystem verschwendeten Platz, Anzahl der Objekte, 3D Balken und Tortendiagramme, das Datum des letzten Zugriffs, Besitzer, NTFS Kompressionsrate und noch vieles mehr an. Außerdem unterstützt es bei der Suche nach überflüssigen, temporären, sehr großen oder sehr alten Dateien. Die Anwendung hat eine intuitive, an den Explorer angelehnte Benutzeroberfläche und arbeitet im Hintergrund. Sie können detaillierte Berichte und Diagramme ausdrucken, oder die gesammelten Daten in eine HTML, XML oder Textdatei speichern, oder in Excel exportieren.

Für jede Schaltfläche und jeden Menüpunkt zeigt TreeSize Professional eine kurze Beschreibung in der Statuszeile des Fensters an. Falls noch Fragen offen bleiben sollen, können Sie JAM Software kontaktieren.

Tipps & Anmerkungen

Einstellungen

Verschwendeter Platz

Diagramme

Drucken

Dateisuche

Registrierung


Schnellstart

Schellstart

1. Hier kann der Benutzer auswählen, welches Laufwerk er scannen möchte. Mit dem Pfeil nebenan startet der Benutzer den Scanvorgang. TreeSize Pro speichert die zuletzt benutzen Pfade in der Dropdown Box.

2. Hier erhält der Benutzer einen Überblickt über das momentan angezeigte Laufwerk. Diese und andere Toolbars können im Kontextmenü deaktiviert werden.

3. Der Reiter "Diagramm" zeigt ein Kuchen- oder Balkendiagramm des aktuell ausgewählten Verzeichnisses an. Mit dem Kontextmenü kann eine Symbolleiste mit weiteren Optionen für Diagramme angezeigt werden.

4. Der Reiter "Details" zeigt detaillierte Informationen über Unterordner und Dateien des ausgewählten Laufwerks bzw. des Ordners.

5. Der Reiter "Dateitypen" zeigt Informationen über die Größe gruppiert nach Dateitypen, so dass man einen Überblick über die Dateitypen erhält, die am meisten Platz verschwenden.

6. Der Reiter "Benutzer" zeigt Informationen über die Größe gruppiert nach Benutzern. Dies erlaubt Ihnen herauszufinden, welcher Benutzer am meistens Platz belegt.

7. Der Dateisystembaum des gescannten Laufwerks bzw. Ordners gibt Ihnen einen schnellen Überblick über die Größe jedes Ordners.

8. Die Statusleiste informiert über den freien und belegten Speicherplatz, den Typ des Dateisystems, usw.


Was ist neu?

Änderungen in Version 3.3:
· Für die Größeneinheiten wurde ein gemischter Modus eingeführt, in dem die Einheit (KB/MB/GB) in Abhängigkeit von dem angezeigten Wert automatisch ausgewählt wird.
· TreeSize Pro wertet nun die Windows Meldungen über Änderungen im Dateisystem aus, um die betroffenen Ordner automatisch im Hintergrund zu aktualisieren. Bereits TreeSize Pro V3.0 hat die Größe eines Verzeichnisses (nicht rekursiv) aktualisiert, wenn dieses auf dem Reiter "Details" aufgelistet worden ist. Alle automatischen Updates können nun über eine neue Schaltfläche in der Symbolleiste ein- und ausgeschaltet werden.
· Eine neue Spalte wurde hinzugefügt, die die Versionsnummer anzeigen kann, die in den meisten EXE, DLL, OCX etc. Dateien enthalten ist. Es wurde außerdem eine Spalte hinzugefügt, die den Titel eines Scans (z.B. Name des Volumes und Laufwerksbuchstaben) anzeigt. Dies kann nützlich bei der Archivierung der gesammelten Daten sein kann.
· Das Kontextmenü der Einträge auf dem Reiter "Details" enthält jetzt ein Untermenü mit allen Informationen über den angewählten Eintrag, darunter auch die von nicht eingeblendeten Spalten. Dieses Menü kann auch zum Ein- und Ausblenden von Spalten verwendet werden.
· Das Hauptmenü hat jetzt einen neuen Punkt "Zweig", der alle Aktionen zusammenfasst, die auf einen kompletten Scan bzw. Zweig angewendet werden können. Der Menüpunkt "Alles aktualisieren", der sämtliche in TreeSize Pro sichtbare Scans aktualisiert, wurde vom Menü "Datei" in das Menü "Extras" verschoben.
· Die Reiter "Benutzer" und "Dateitypen" verfügen jetzt über ein kleines horizontales Balkendiagramm dass die Verteilung der Größen auf die einzelnen Benutzer / Dateitypen visualisiert.
· Der neue Kommandozeilen-Parameter /EXCLUDE erlaubt die Angabe von Mustern, die beim Scannen ignoriert werden sollen.
· Der neue Kommandozeilen-Parameter /OPEN ermöglicht das Öffnen eines gespeicherten XML Reports beim Programmstart. Sie kann mit /COMPARE kombiniert werden.
· TreeSize Pro wird jetzt mit einer XSLT-Datei geliefert, die den Inhalt einer gespeicherten XML-Datei für die Darstellung in einem Web Browser (z.B. Firefox >V1.0 und Internet Explorer >V5.5) visualisiert. Bei umfangreichen XML-Dateien benötigen die Browser aber möglicherweise eine längere Zeit zum Verarbeiten der Daten.
· Wird ein Laufwerk oder ein Pfad aus der Dropdown Box in der oberen linken Ecke des Hauptfensters ausgewählt, so startet der Scan jetzt sofort. Das Drücken der Schaltfläche zum Starten daneben ist nun nicht mehr erforderlich.
· Der Forschritt beim Drucken eines Reports und beim Vergleichen mit einer XML Datei werden jetzt in einem kleinen Fortschrittsfenster angezeigt.
· Die zusätzliche Spalte "TreeSize" für den Windows Explorer folgt jetzt keinen symbolischen Links und Mountpoints mehr, um mit dem Windows Explorer konsistente Ergebnisse zu liefern und lange oder unerwünschte Rekursionen im Dateisystem zu vermeiden.
· Bugfix: Der Kommandozeilen-Parameter /EXTENSIONSLIST hat nicht korrekt funktioniert.
· Einige kleinere Fehler wurden behoben und weitere kleine Verbesserungen sind eingeflossen.

Änderungen in V3.22:
· Der freie Plattenplatz wird jetzt auch für Netzwerklaufwerke im Tortendiagramm angezeigt. Die Anzeige des freien Platzen kann über das Kontextmenü des Tortdiagramms ein bzw. ausgeschaltet werden.
· Das Format der Hilfedatei wurde von Winhelp (.HLP) auf HTMLHelp (.CHM) umgestellt.
· Alle Exporte sind nun etwas schneller
· Der Excel Export ist jetzt robuster gegenüber bereits in den Excel-Dateien enthaltenen Daten. Sind die Kopfzeilen in den Optionen deaktiviert, so werden jetzt oberhalb der Daten keine Leerzeilen mehr gelassen.
· Einige kleinere Korrekturen

Änderungen in V3.21:
· Es wurden einige unkritische Fehlermeldungen beseitigt, die gelegentlich beim Beenden des Programms auftraten, wenn noch Scans aktiv waren.
· Es gibt im Menü "Ansicht" jetzt wieder den Menüpunkt zum Ein- und Ausblenden der Symbolleisten.
· Bugfix: Die Sortierreihenfolge war teilweise falsch, wenn die Ansicht auf einen Benutzer oder einen Dateityp eingeschränkt war.
· Bugfix: Die Beschriftung [Dateien] hat bei den gedruckten Berichten gefehlt.
· Die neue zusätzlich TreeSize Spalte für den Windows Explorer sortiert nun auch korrekt. Um dies zu erreichen, musste von KB nach MB gewechselt werden und das Tausendertrennzeichen weggelassen werden. Dateien größer als 4GB werden nun ebenfalls korrekt behandelt. Außerdm kann die Spalte jetzt einfacher über das Kontextmenü der Spaltenköpfe des Windows Explorer aktiviert werden.
· Weitere kleinere Verbesserungen.

Änderungen in V3.2:
· TreeSize Pro wird jetzt mit einer Shell Extension ausgeliefert, die eine zusätzliche Spalte zum Windows Explorer hinzufügt. Diese Spalte zeigt die Größe nicht nur für Dateien sondern auch für Ordner an und ist dazu gedacht sich einen schnellen Überblick zu verschaffen. Die Spalte kann im Windows Explorer unter "Ansicht / Details auswählen" aktiviert werden.
· Vergleichbar mit der Funktion "Linke Seite auf diesen Benutzer einschränken" aus der Benutzer-Ansicht ist es jetzt möglich, die linke Seite nachträglich auf eine bestimmte Dateiendung einzuschränken.
· Die Dateisuche verfügt jetzt über einen zusätzlichen Reiter "Optionen für Anzeige", mit dem sich die Anzahl der Dezimalstellen und die Einheit (KB, MB, GB, Gemischt) für die Anzeige der Dateigrößen in den Ergebnislisten einstellen lässt.
· Passt eine Datei zu mehr als einer Suchart der Dateisuche, so erscheint sie jetzt in allen Ergebnislisten, und nicht nur in der ersten.
· Die Dateisuche startet jetzt einen eigenen Thread für jedes ausgewählte Laufwerk bzw. jeden ausgewählten Pfad, was die Geschwindigkeit erhöhen sollte.
· Der ausgewählte Drucker und die Orientierung des Papiers werden jetzt gespeichert und beim nächsten Start wieder hergestellt.
· Die Geschwindigkeit des Exports wurde erhöht. Außerdem erscheint jetzt beim Export und beim Speichern ein Fortschrittsbalken.
· Die Exportroutinen "Als Textdatei speichern" und "Kopieren" nutzen den Speicher jetzt effizienter aus, so dass keine Fehlermeldungen über nicht ausreichenden Hauptspeicher mehr auftreten sollten.
· Die nach Excel exportierten Arbeitsblätter sind jetzt mit dem aktuellen Datum anstatt mit "Tabelle 1" etc. beschriftet.
· In den Optionen kann jetzt für jedes Exportmedium einzeln festgelegt werden, ob eine Kopfzeile hinzugefügt werden soll.
· Exportierte Dateien enthalten jetzt Informationen über aktive Filter sowie eine Information darüber, ob die Sicht auf einen Benutzer oder eine Dateiendung eingeschränkt war.
· Die Funktion "Kopiere Dateiliste" exportiert jetzt auch das Erstellungs- datum der Dateien.
· Neue Kommandozeilen Option /USERSLIST die das exportieren der Benutzerliste in eine Datei erlaubt.
· Weitere kleinere Verbesserungen

Änderungen in V3.13
· Bugfix: In vorangegangenen Versionen wurden Dateien, deren Größe nur um wenige Bytes differierte, unter Umständen nicht korrekt in der Detail-Liste sortiert.
· Bugfix: Das Selektieren einer Großen Anzahl von Einträgen in der Detail-Liste nahm eine sehr lange Zeit in Anspruch. Die wurde jetzt optimiert.
· Die Größen im Dateisystembaum werden jetzt aktualisiert, wenn eine Datei in der Detail-Liste gelöscht wird.
· Bugfix: Die letzte Spalte hat in exportierten Dateien hat gefehlt.
· Bugfix: Der Menüpunkt "Liste Speichern" in der Liste der Dateiendungen hat nicht korrekt funktioniert.
· Für exportierte Textdateien wird jetzt das in der Systemsteuerung festgelegte Listentrennzeichen verwendet, anstatt standardmäßig der Tabulator.
· Dies soll die Kompatibilität mit anderen Anwendungen wie Tabellenkalkulationen und Datenbanken erhöhen. Falls Sie exportierte Dateien automatisiert weiterverarbeiten, müssen Sie unter Umständen Ihre Skripte der die Einstellung in der Systemsteuerung modifizieren.
· Bugfix: Wenn die Ansicht auf einen Benutzer eingeschränkt war, wurden alle Dateien in der Detail-Liste mit der Größe 0 gelistet, unabhängig von ihrer tatsächlichen Größe.
· Wenn der Baum auf einen bestimmten Benutzer eingeschränkt wird, so wird dieser in der Liste der Benutzer nun fett angezeigt.
· Bugfix: Wurde die Baumansicht auf einen Benutzer eingeschränkt, so wurde als Größe in den [Dateien] Einträgen immer 0 angezeigt.
· Die Geschwindigkeit der Dateisuche wurde erhöht.

Änderungen in V3.1:
· Verbesserungen der Benutzeroberfläche, Verbessertes Aussehen unter dem XP-Style, Neue Icons.
· Diagramme können jetzt auch im PNG-Format gespeichert werden.
· Einzelne Spalten in der Detail-Liste können jetzt auch mittels des Kontextmenüs des Spaltenkopfes aktiviert und deaktiviert werden, ähnlich wie beim Windows Explorer.
· Neue Spalte, die die durchschnittliche Dateigröße anzeigt.
· Neue Spalte, die die Zugriffsberechtigungen von Benutzern und Gruppen für Ordner und Dateien anzeigt.
· Balkendiagramme, die als Grafik abgespeichert werden, enthalten jetzt alle Balken, und nicht wie vorher nur die im Fenster sichtbaren.
· Excel Dateien werden jetzt ohne die Hilfe von MS Excel erstellt, so dass keine installierte Version von MS Excel mehr vorausgesetzt wird. Zusätzlich läuft der Excel Export jetzt auch schneller und stabiler als vorher.
· In den Optionen kann jetzt eine Standard-Datei für den Excel-Export angegeben werden. Diese wird immer beim manuellen starten des Excel Exports verwendet. Um die Datei zu ändern, wählen Sie bitte in den Optionen auf dem Reiter "Spalten" in der Dropdown Box "Excel" aus.
· Es kann jetzt für jedes Export-Medium einzeln eingestellt werden, ob nur die aufgeklappten Teile des Verzeichniszweiges exportiert werden sollen, oder der gesamte Verzeichnisbaum. Diese Einstellung kann in den Optionen auf der Seite "Spalten" angepasst werden.
· Neue Kommandozeilen Option /COMPARE, die ein Verzeichnis nach abgeschlossenem Scan mit einem gespeicherten XML-Report vergleicht. Diese Option kann mit anderen Kommandozeilen Optionen kombiniert werden, um beispielsweise die Ergebnisse eines Vergleichs in eine Excel Datei zu speichern.
· An der Kommandozeile werden jetzt Platzhalter unterstützt, z.B. \\Server\Users\A*
· Im Kontextmenü des Kreisdiagramms gibt es jetzt eine Option, mit der sich die Anzeige des freien Plattenplatzes für die Wurzel ein- und ausschalten lässt.
· Wird der Verzeichnisbaum auf einen bestimmten Benutzer eingeschränkt, so zeigt die Detail-Liste jetzt nur noch Dateien dieses Benutzers an.
· Für bekannte Dateiformate wird jetzt ein Vorschaubild in der rechten unteren Ecke des Fensters der Dateisuche angezeigt.
· Die Minimalgröße für die Suche nach den größten Dateien wurde in der Vorversion nicht gespeichert. Dies ist jetzt korrigiert.
· Einige weitere kleine Fehlerkorrekturen und Verbesserungen wurden eingearbeitet.

Änderungen in V3.03:
· Wenn ein Verzeichnis ohne Unterverzeichnisse angewählt wird, werden nun die Dateien in diesem Verzeichnis im Diagramm angezeigt.
· Bugfix: In der Suche nach ältesten Dateien wurde bei aktivierter Option "Nur komplette Verzeichnisse" nicht die korrekten Icons für die Verzeichnisse angezeigt.
· Bugfix: In der Suche nach ältesten Dateien wurden bei aktivierter Option "Nur komplette Verzeichnisse" die Verzeichnisgrößen nicht korrekt berechnet.
· Bugfix: Das falsche Kontextmenü wurde für die [Dateien] Einträge im Baum angezeigt.
· Bugfix: Das Verändern der Einheit (KB, MB, GB) während des Scans führte nicht immer zu einer Aktualisierung des kompletten Dateisystem-Baumes.
· Einige kleinere Bugfixes sind ebenfalls in diese Version eingeflossen.

Änderungen in V3.02:
· Die Exclude-Muster der Dateisuche wurden bislang nicht gespeichert. Dies wurde jetzt geändert.
· Unter Bestimmten Bedingungen wurden nicht alle Dateien, die in der Dateisuche angewählt waren, auch tatsächlich verschoben.
· Beim Speichern der Suchergebnisse der Dateisuche kann jetzt auch das CSV-Format ausgewählt werden, welches kompatibler mit Excel ist.

Änderungen in V3.01:
· Der Export in eine Textdatei produzierte eine leere Datei, wenn die Option "Kopfzeile" im Export-Menü nicht aktiviert war.
· Es wurde ein Fehler in der Dateisuche beseitigt, der aufgetreten ist, wenn zum Sortieren auf den Spaltenkopf der Spalte mit dem Dateityp geklickt worden ist.
· Die Bilder in der Hilfe-Datei und dem PDF-Handbuch haben gefehlt.
· In sehr seltenen Fällen kam es beim Programmstart zu einer Fehlermeldung, wenn die MAPI32.DLL nicht gefunden worden ist.

Änderungen in V3.0:
· TreeSize Pro kann die Ergebnisse jetzt in einer zusätzlichen Liste gruppiert nach Benutzern anzeigen. Die Daten in der Verzeichnisstruktur lassen sich außerdem auf einen Benutzer einschränken.
· TreeSize Pro kann jetzt seine Daten in eine XML-Datei speichern und später wieder laden.
· Eine gespeicherte XML-Datei kann zum Vergleich mit dem derzeitigen Stand des Dateisystems genutzt werden. Es wird dann die Differenz der beiden Scans angezeigt, was das Erkennen von stark gewachsenen Ordnern erleichtert.
· Die Spalten können jetzt in Abhängigkeit vom Ausgabe-Medium (TreeSize Pro Fenster, ASCII-Datei, Excel, gedruckter Report) ausgewählt und sortiert werden.
· Es sind neue Spalten hinzugekommen: Attribute, Verzeichnisebene, Dateityp
· Eine neue Symbolleiste gibt jetzt einen schnellen Überblick über das gescannte Verzeichnis.
· Ein Report kann jetzt per E-Mail (via MAPI) versandt werden.
· Es ist jetzt möglich, in den Optionen den Scan auf Dateien einzuschränken, die das Archiv-Attribut gesetzt haben. Auf diese Weise kann man z.B. die Größe von Backups ermitteln.
· TreeSize Pro scannt jetzt Ordner die auf sein Fenster gezogen werden.
· Im Kontextmenü gibt es nun einen Eintrag "Aus TreeSize entfernen", der den betreffenden Ordner aus dem Verzeichnisbaum von TreeSize entfernt (ohne ihn auf dem Laufwerk tatsächlich zu löschen) und die Verzeichnisgrößen neu berechnet.
· In den Optionen können Sie einen Scan jetzt auf Dateien einschränken, die in den letzten XX Tagen erstellt worden sind. Auf diese Weise können Ordner identifiziert werden, die in jüngster Zeit stark angewachsen sind.
· Der Inhalt aller Listen kann jetzt über deren Kontextmenü in die Zwischenablage exportiert werden.
· Das Kontextmenü des Verzeichnisbaumes bietet jetzt die Möglichkeit, auch Unterzweige in die Zwischenablage zu kopieren.
· Wenn ein ausgewählter Ordner in der Detailansicht angezeigt wird, berechnet TreeSize Pro die Verzeichnisgröße für dies Verzeichnis jetzt neu und aktualisiert seine Daten.
· Es gibt jetzt ein Kontextmenü zum Ein- und Ausblenden der einzelnen Symbolleisten
· Die ausgewählte Größeneinheit wird jetzt auch für die Anzeige der Werte in der Statusleiste verwendet.
· Mit dem neuen Kommandozeilen-Parameter /TITLE kann der Standard-Titel, der beim Exportieren oder Drucken verwendet wird, verändert werden. Auf diese Weise können Sie beispielsweise in einer automatisierten Umgebung zusätzliche Informationen übermitteln.
· Neuer Kommandozeilen-Parameter /EMAIL zum Versenden eines Reports per Mail
· Neuer Kommandozeilen-Parameter /FILTER zum Einschränken des Scans auf bestimmte Dateitypen.
· Neuer Kommandozeilen-Parameter /RESTRICTED der TreeSize Pro in eine Art "nur lesen"-Modus versetzt, der keine Manipulationen am Dateisystem erlaubt.

Dateisuche:
· Es ist jetzt möglich, die markierten Dateien nicht nur zu löschen, sondern auch in eine ZIP-Datei zu verschieben.
· Die Dateisuche verfügt jetzt über eine Exclude-Liste. Eine Datei oder ein Ordner, das eines der angegebenen Strings enthält, wird in den Ergebnissen nicht berücksichtigt.
· Dateien die mit dem Attribut FILE_ATTRIBUTE_TEMPORARY erstellt worden sind, Können jetzt in die Suche nach temporären Dateien einbezogen werden.
· Ebenfalls kann jetzt nach Dateien gesucht werden, die keinem existierenden Benutzer zugeordnet sind.
· Es kann jetzt auch nach Verknüpfungen gesucht werden, die kein gültiges Ziel mehr haben.
· Jedes Suchmuster bei der Suche nach temporären Dateien hat jetzt eine Checkbox, mit der es individuell aktiviert und deaktiviert werden kann.
· Die Größe von Ordnern wird jetzt in der Dateisuche angezeigt.
· Der Kommandozeilen-Parameter /SAVE funktioniert jetzt auch mit der Dateisuche und speichert die Suchergebnisse in einer Textdatei

Neue Funktionen in V2.4:
· TreeSize Professional kann nun Verzeichnisse unter Windows NT4/2000 untersuchen, auf die der aktuelle Nutzer eigentlich keinen Zugriff hat. Man muss sich dazu entweder als Administrator angemeldet haben, oder als Nutzer, der das Recht hat, Backups durchzuführen. In den vorangegangenen Versionen von TreeSize Professional wurde hier lediglich die Fehlermeldung "Zugriff verweigert" angezeigt.
· Es gibt eine neue Option im Einstellungen-Dialog, mit der festgelegt werden kann, ob TreeSize Professional beim Scannen Mountpoints und symbolischen Links folgen soll oder nicht. (Dies sind neue Funktionen von Windows 2000)
· TreeSize Pro berücksichtigt nun die Kompression auf NTFS Laufwerken bei der Berechnung des Belegten Platzes.
· Komprimierte Dateien und Verzeichnisses in blauer Farbe angezeigt werden. Wenn nur ein Teil eines Verzeichnisses komprimiert ist, wird dieses in dunkelblau angezeigt.
· In einer zusätzlichen Spalte in der Detailansicht wird nun die Kompressionsrate von Dateien und Verzeichnissen auf angezeigt.
· Die Einstellung, ob die Werte in KB oder MB angezeigt werden, wurde zwecks schnelleren Zugriffs vom Einstellungen-Dialog in die Symbolleiste verlagert.
· Die Diagramme können jetzt auch als JPG-Datei gespeichert werden.
· Es besteht jetzt die Möglichkeit des HTML-Exports. Dies kann entweder in Hauptmenü unter Datei/Export/Als HTML Speichern oder mit der Kommandozeilen-Option /HTML geschehen. HTML Reporte haben den Vorteil, dass sie einfacher zu lesen sind als Text Reporte und es wird keine spezielle Anwendung wie MS Excel benötigt.
· Das Software Applet der Systemsteuerung kann jetzt aus der Symbolleiste von TreeSize aufgerufen werden.
· Neben der Funktion, Verzeichnisse in fetter Schriftart anzuzeigen, die größer als ein einstellbarer Prozentsatz des untersuchten Verzeichnisses sind, kann jetzt alternativ auch ein fixer Schwellwert in MB angegeben werden. Diese Einstellung kann jetzt auch für den Druck von Reporten verwendet werden und verschafft so einen schnelleren Überblick über die größten Verzeichnisse.
· Es ist jetzt möglich, alle sichtbaren Freigaben eines Servers auf einmal zu untersuchen, indem man den Namen des Servers in der Form \\HOSTNAME in die Laufwerksbox in der Symbolleiste eingibt.
· Die Laufwerksbox verfügt bei der manuellen Eingabe jetzt über eine AutoComplete Funktion ähnlich den neuen Versionen des Windows Explorer.
· Neue Option im Einstellungen-Dialog: Die Diagramme und die Detailansicht können jetzt während dem Scannen automatisch aktualisiert werden.
· Eine zusätzliche Spalte der Detailansicht zeigt jetzt unter Windows NT4/2000 den Namen des Dateibesitzers an.
· Dateien, die noch geöffnet sind, werden jetzt automatisch von den Suchergebnissen der Dateisuche ausgeschlossen.
· Große Balkendiagramme können jetzt mit dem Mausrad gescrollt werden. Tortendiagramme können mit dem Mausrad rotiert werden.
· Die Kommandozeilenoption /CHART wurde durch /BARCHART und /PIECHART ersetzt.
· Tsizepro.exe wurde mit UPX komprimiert.


Tipps & Anmerkungen

· Besonders auf großen Netzwerklaufwerken kann ein Scan sehr lange dauern. Sie können in diesem Fall auch Scans über Nacht mit Hilfe der Kommandozeilen-Parameter von TreeSize Professional 3 durchführen und die Ergebnisse in einer XML-Datei speichern. Diese Daten können später wieder in TreeSize Professional 3 geladen und analysiert werden.
· Alle Verzeichnisse, die im Verzeichnisbaum in der linken Hälfte des Fensters sichtbar sind, werden auch im gedruckten Bericht oder der exportierten Datei zu sehen sein. Sie können in den Optionen aber auch einstellen, dass stets der gesamte Verzeichnisbaum exportiert bzw. gedruckt wird.
· Das Datum des letzten Zugriffs ist das Datum, an welchem eine Datei zuletzt benutzt oder geladen wurde. Für Programme oder DLLs ist dies zum Beispiel das Datum, an dem Sie zuletzt ausgeführt wurden und für Grafiken, wann sie zum letzten Mal angezeigt worden sind. Wenn also auf eine Datei seit längerer Zeit nicht zugegriffen wurde, wird diese auf Ihrem System wahrscheinlich nicht mehr benötigt. Das Datum des letzten Zugriffs kann beispielsweise dazu verwendet werden, überflüssige DLLs im Windows Systemverzeichnis zu identifizieren.
· Mit der Festlegung einer benutzerdefinierten Blockgröße können Sie testen, wie die Werte für den belegten und verschwendeten Platz Ihrer Festplatte mit einer anderen Blockgröße aussehen würden. Dazu ist allerdings ein erneutes Einlesen Ihrer Verzeichnisstruktur notwendig.
· Verwenden Sie die CD-ROM Blockgröße um zu sehen, wie viel Platz ein Verzeichnis auf einer CD-ROM belegen würde. Bitte beachten Sie dabei, dass auf einer CD-R(W) noch zusätzlich einige MB für die Verzeichnisinformationen benötigt werden.
· Im Papierkorb werden Sie nicht die selbe Darstellung wie im Explorer sehen. Dies ist notwendig, um den tatsächlich belegten Platz und das Datum des letzten Zugriffs zu bestimmen.
· Sie können alle freigegebenen Laufwerke einer Domäne scannen, in dem Sie den Namen der Domäne einfach in die Laufwerksbox von TreeSize Professional 3 eingeben.
· TreeSize Professional 3 wird mit einer XSLT-Datei ausgeliefert, die die Daten ein solchen XML Datei für die Darstellung in XSLT-fähigen Browser konvertiert (z.B. Firefox >V1.0 oder Internet Explorer >V5.5).
· Verwenden Sie die Dateisuche um überflüssige Dateien auf ihren Laufwerken zu suchen.
· Für die Überwachung und Verwaltung sehr großer Server empfehlen wir Ihnen unser Produkt SpaceObServer, dass Laufwerke mittels eines Hintergrunddienstes einliest und seine Daten in einer SQL-Datenbank ablegt. Es benötigt wesentlich weniger Hauptspeicher und bietet wesentlich flexiblere Reporting Funktionen wie z.B. Historien. Mehr über dieses Produkt erfahren Sie unter: http://www.jam-software.de/spaceobserver/


TreeSize Spalte für den Explorer

TreeSize Professional 3 wird jetzt mit einer Shell-Erweiterung ausgeliefert, die dem Windows Explorer eine zusätzliche Spalte hinzufügt. Diese Spalte zeigt die Größe nicht nur für Dateien sondern auch für Ordner an und ist dazu gedacht sich einen schnellen Überblick zu verschaffen. Die Spalte kann im Windows Explorer unter Ansicht / Details auswählen aktiviert werden, oder über das Kontextmenü der Kopzeile der Detailansicht des Windows Explorer. Die Spalte steht nicht für Windows 95/98 zur Verfügung.

treesize-explorer-column


Verschwendeter Platz

Der verschwendete Platz ist der ungenutzte Platz in Festplattenblöcken, die nicht komplett gefüllt sind. Dies ist jeweils bei dem letzten (oder einzigen) Block einer Datei der Fall. Behalten Sie immer folgende Formel im Hinterkopf: Größe + verschwendeter Platz = belegter Platz. Windows 95 mit seinem Dateisystem FAT kann abhängig von der Größe der Partition sehr große Blockgrößen haben:

FAT FAT32
Partitionsgröße Clustergröße Partitionsgröße Clustergröße
128 - 256 MB 4 KB 1 - 8 GB 4 KB
257 - 512 MB 8 KB 8 - 16 GB 8 KB
513 - 1024 MB 16 KB 16 - 32 GB 16 KB
1025 - 2048 MB 32 KB >32 GB 32 KB

Wenn Sie beispielsweise eine Partition der Größe 1,2GB haben, werden darauf Blöcke der Größe 32KB verwendet. Wenn Sie dort nun 10 Dateien mit einer Größe von je 1KB speichern wollen, würden Sie dazu 10*32KB=320KB Ihres wertvollen Festplattenplatzes benötigen, und 320KB-10KB=310KB wären verschwendeter Platz.

Um den verschwendeten Platz zu reduzieren, haben Sie folgende (nicht immer befriedigenden) Möglichkeiten:

· Erstellen Sie kleinere Partitionen. Sie sollten FAT32 Partitionen größer als 16GB vermeiden. Allerdings bedeuten kleinere Partitionen auch eine größere Anzahl von Partitionen und somit von Laufwerksbuchstaben.

· Windows NT/2000/XP bieten die Möglichkeit, auf einer Partition das NTFS Dateisystem zu verwenden. Es arbeitet normalerweise mit Blockgrößen von 512-4096 Bytes und speichert Daten deshalb am effizientesten von allen Windows Dateisystemen. NTFS Partitionen können allerdings nicht von Windows 9x oder DOS aus angesprochen werden. Zusätzlich bietet NTFS noch die Möglichkeit, einzelne Verzeichniszweige zu komprimieren.


Drucken

TreeSize Professional hat umfangreiche und flexible Druck-Funktionen:

Sie können einen detaillierten Bericht drucken, indem Sie im Datei-Menü 'Drucke Bericht' auswählen oder in der Symbolleiste die Schaltfläche mit dem Druckersymbol drücken. Der Bericht enthält die Verzeichnisstruktur des untersuchten Ordners inklusive Linien zwischen den Verzeichnissen, Größe, belegtem Platz, Anteil am übergeordneten Verzeichnis in Prozent, das Datum des letzten Zugriffs und der letzten Änderung sowie die Anzahl der im Ordner enthaltenen Objekte. Es werden nur die Ordner im Bericht gedruckt, die auch im Verzeichnisbaum im linken Teil des Fensters von TreeSize Professional sichtbar sind. So können Sie auf einfache Weise den Umfang des Berichts anpassen. Wenn Sie einen kompletten Bericht wünschen, wählen Sie zuvor 'Alles Einblenden' aus dem Kontextmenü des obersten Ordners.

Die Spalten, die ein Bericht enthalten soll, kann in den Optionen festgelegt werden.

Wenn die Detailansicht in der rechten Hälfte des Fensters aktiv ist, können Sie den Inhalt eines Ordners drucken, indem Sie 'Drucke Ordnerinhalt' aus dem Datei-Menü wählen. Im Ausdruck sind alle Dateien und Unterordner enthalten, mit Angabe der Größe, dem belegten und verschwendeten Platz, der Anzahl der Objekte sowie dem Datum des letzten Zugriffs und der letzten Änderung.

Wenn in der rechten Hälfte des Fensters ein Diagramm sichtbar ist, können Sie dieses Diagramm ausdrucken, indem Sie 'Drucke Diagramm' aus dem Datei-Menü auswählen. Das Diagramm wird genauso gedruckt, wie es am Bildschirm angezeigt wird.

Verwenden Sie den Menüpunkt 'Seite einrichten' um die Ränder für den Druck einzustellen. Verwenden Sie den Menüpunkt 'Drucker einrichten' um einen Drucker auszuwählen und einzurichten. Mit dem Menüpunkt 'Titel angeben' können Sie einen Titel für den Druck und Export festlegen, standardmäßig besteht dieser aus dem Verzeichnispfad und dem Namen des Laufwerks.


Diagramme

TreeSize Professional kann die Belegung der Festplatte in Form von Balken- und Tortendiagrammen visualisieren. Ein Diagramm zeigt jeweils die Größe der Unterordner des gerade ausgewählten Ordners an. Ein Tortendiagramm zeigt die Größe, den belegten Platz, verschwendeten Platz etc. an, je nachdem welche Ansicht gerade aktiv ist. Ein Balkendiagramm zeigt Größe, belegten und verschwendeten Platz eines Ordners in einem Balken an, hier gilt die Formel: Belegter Platz = Größe + verschwendeter Platz. Wenn nicht alle Balken in das Fenster von TreeSize Professional passen, wird am rechten Rand eine Bildlaufleiste eingeblendet.

Im Tortendiagramm werden kleinere Verzeichnisse zur besseren Übersicht unter "Andere" zusammengefasst. Falls das Wurzelverzeichnis eines Laufwerks angezeigt wird und sich TreeSize im Ansichtsmodus "Belegter Platz" befindet, wird auch der freie Platz des Laufwerks im Tortendiagramm angezeigt. Im Kontextmenü des Tortendiagramms gibt es einen Menüpunkt, um dieses Verhalten ein- oder auszuschalten.

Durch Klicken auf einen Balken oder einen Teil eines Tortendiagramms erhält man ausführlichere Informationen über den dazugehörigen Ordner. Ein Doppelklick macht den ausgewählten Ordner zum aktiven Ordner. In den Einstellungen können Sie die Option 'Symbolleiste für Charts' auswählen, um eine zusätzliche Symbolleiste zur erweiterten Manipulation von Diagrammen einzublenden. Diese ermöglicht zum Beispiel das Speichern des Diagramms als Bitmap- oder JPEG-Datei, Zoomen, das Ändern von Farben und Mustern, das Ein- und Ausblenden der Gitternetzlinien, das Umschalten zwischen 2D und 3D Modus, etc. Sie können Muster und Farben einzelner Diagrammelemente ändern, indem Sie in der Auswahlbox eine Farbe auswählen und anschließend auf ein Diagrammelement klicken.

Ein Diagramm kann gedruckt werden, indem Sie 'Drucke Diagramm' aus dem Datei-Menü auswählen.


Kommandozeilen Parameter

TreeSize Professional 3 akzeptiert Kommandozeilen Parameter, die zeitgesteuerte Untersuchungen erlauben.

Tsizepro.exe [/ARCHIVEBITFILESONLY] [/(BAR|PIE)CHART filename] [/COMPARE] [/DATE] [/EMAIL] [/EXCEL filename] [/EXPAND [level|xxMB]] [/FILTER pattern1;pattern2;...] [/HTML filename]  [/NOGUI] [/PRINT] [/SAVE filename] [/SEARCH[:Start|:Internet]] [/TITLE text] [/USERSLIST filename] [/XML]  Directories

/ARCHIVEBITFILESONLY Diese Option wird nur solche Dateien in die Scans mit einbeziehen, bei denen das Archiv Bit gesetzt ist. Dies kann beispielsweise genutzt werden, um die Größe von Backups zu bestimmen. In diesem Fall können Sie eine Verknüpfung zu TreeSize Professional 3 auf dem Desktop oder im Startmenü erstellen, die automatisch mit der Berechnung der Größe des Backup beginnt:

tsizepro /ARCHIVEBITFILESONLY \\Server\Backup\This

/BARCHART Speichert das Balkendiagramm des untersuchten Verzeichnisses als Bitmap oder JPEG Datei, der Typ der Datei wird über die Dateiendung bestimmt. Beispiel:

tsizepro /CHART C:\Documents\c.jpg C:\

/COMPARE Vergleicht den untersuchten Pfad oder dens geöffneten XML-Report mit einem gespeicherten XML Report. Das folgende Beispiel untersucht das Laufwerk C: und vergleicht es anschließend mit einem gespeicherten XML Report für dieses Laufwerk:

tsizepro /COMPARE "C:\temp\TSP XML\c.xml" C:\

/DATE Diese Option fügt zu jedem Dateinamen, in dem Ergebnisse gespeichert werden und die nach dieser Option auftauchen, Datum und Uhrzeit hinzu. Dies ist besonders nützlich, wenn man regelmäßig zeitgesteuerte Untersuchungen durchführt. Wenn allen Dateinamen Datum und Uhrzeit hinzugefügt werden soll, sollte /DATE der erste Kommandozeilen Parameter sein. Das folgende Beispiel würde den Netzwerkpfad \\host\\share untersuchen und das Ergebnis unter einem Dateinamen der Art C:\scans\name_99-12-20_1550.xls speichern:

tsizepro /DATE /EXCEL C:\scans\name.xls \\host\share

/EMAIL Sendet die gesammelten Daten an die angegebene E-Mail Adresse über die MAPI-Schnittstelle von Windows. MAPI muss daher in der Systemsteuerung geeignet konfiguriert sein. Es können mehrere Empfänger angegebene werden, die jeweils durch ein Semikolon oder Komma getrennt werden müssen. Beispiel:

tsizepro /EMAIL sysadmin@company.com \\SERVER\C$

/EXCEL Exportiert die gesammelten Ergebnisse in Excel und speichert sie unter dem angegebenen Namen ab. Existiert die Datei bereits, so wird sie geöffnet und die Ergebnisse auf einem neuen Tabellenblatt hinzugefügt. TreeSize Professional 3 wird anschließend beendet. Beispiel:

tsizepro /EXCEL C:\Dokumente\c.xls C:\

/EXCLUDE Diese Option erlaubt die Angabe von Mustern für Dateien und Ordner, die beim Untersuchen der Platte ignoriert werden sollen. Mehrere Muster können jeweils durch ein Semikolon getrennt werden. Enthält ein Suchmuster Leerzeichen, so muss der gesamte String in Anführungszeichen gesetzt werden, so wie es im Beispiel unten zu sehen ist. Diese Kommandozeilen-Option entspricht den Ausschlusskriterien in den Optionen. Das folgende Beispiel würde Ordner und Dateien ignorieren, die auf ".001" enden sowie die den Namen ".personal" haben:

   tsizepro /EXCLUDE "*.001;.system" \\server\Users

/EXPAND Mit diesem Parameter kann festgelegt werden, wie viele Ebenen des Verzeichnisbaumes eingeblendet werden, nachdem die Untersuchung abgeschlossen ist. Wird keine Zahl angeben, so wird der Verzeichnisbaum komplett eingeblendet. Es kann auch eine Angabe in MB gemacht werden was dazu führt, dass alle Verzeichnisse, die größer als der angegebene Wert sind, eingeblendet werden. Bitte beachten Sie, dass sich zwischen der Zahl und der Einheit "MB" kein Leerzeichen befinden darf. Beispiele:

tsizepro /EXCEL C:\Results\Allusers.xls /EXPAND 2 H:\user

   tsizepro /EXCEL C:\Results\C.xls /EXPAND 10MB C:\

/EXTENSIONSLIST Diese Option schreibt die Statistik über die Verteilung der Dateieypen / Dateiendungen des untersuchten Dateisystemzweiges in eine Text- oder CSV-Datei. Das folgende Beispiel untersucht Laufwerk C: und erstellt eine CSV-Datei in C:\Temp mit der Statistik der Dateitypen auf diesem Laufwerk:

   tsizepro /EXTENSIONSLIST C:\temp\C_filetypes.csv C:\

/FILTER Erlaubt das Setzen eines Filters, so dass nur bestimmte Dateitypen wie *.MP3 oder *.DOC in den Scan mit einbezogen werden. Es können mehrere Filter übergeben werden, die mittels Leerzeichen, Kommata oder Semikola getrennt werden müssen. Das folgende Beispiel sucht nach AVI- und MP3-Dateien im Verzeichnis "Users"direkt auf dem Server:

tsizepro /EXCEL C:\Results\MediaUsers.xls /FILTER "*.mp3;*.avi" \\Server\Users

/HTML Speichert die gesammelten Daten in eine HTML-Datei, welche dann mit jedem Internet-Browser angeschaut werden kann. Wird zusätzlich noch der Parameter /PIECHART oder /BARCHART angegeben, wird das entsprechende Diagramm in die resultierende HTML-Datei eingebettet. Das folgende Beispiel erzeugt einen HTML-Report für das Laufwerk C:und speichert diese im Verzeichnis D:\html:

tsizepro /DATE /HTML d:\html\treesize.html /PIECHART d:\html\treesize.jpg C:\

Wenn Sie gerne mehrere Verzeichnisse oder Laufwerke untersuchen und exportieren möchten, empfehlen wir, entweder einen gesonderten Aufruf von TreeSize Professional 3 für jedes Laufwerk / Verzeichnis, oder die Kommandozeilen Parameter in der folgenden Art zu verwenden:

tsizepro /HTML d:\html\drive_c.html /PIECHART d:\html\drive_c.jpg C:\ /HTML d:\html\drive_d.html /PIECHART d:\html\drive_d.jpg D:\

/NOGUI Dieses Argument bewirkt, dass das Fenster von TreeSize Pro nicht angezeigt wird und nicht in der Taskleiste erscheint. Achtung: Verwenden Sie dieses Argument erst, wenn Sie die restlichen Kommandozeilen Parameter ausreichend getestet haben!

/OPEN Öffnet einen gespeicherten XML Report beim Start der Anwendung. Beispiel:

tsizepro /OPEN C:\Reports\Lfw_C.xml

/PIECHART Speichert das Kreisdiagramm des untersuchten Verzeichnisses als Bitmap oder JPEG Datei. Das folgende Beispiel scannt die Laufwerke C:\ und D:\ und erstellt für jedes einen Chart:

tsizepro /PIECHART C:\Temp\c.jpg C:\ /PIECHART C:\Temp\d.jpg D:\

/PRINT druckt einen Bericht auf dem Standard Drucker aus und beendet die Anwendung anschließend. Beispiel:

tsizepro /PRINT C:\ D:\

/PRINT1 Druckt nur die erste Seite des Reports für jedes angegebene Verzeichnis / Laufwerk auf dem Standard Drucker aus und beendet TreeSize Professional 3 anschließend. Beispiel:

tsizepro /PRINT1 \\SERVER\USERS

/RESTRICTED Startet TreeSize Professional 3 in einer Art "Readonly"-Modus, in denen der Benutzer keinen Zugriff auf das Explorer-Kontextmenü hat, keine Dateien oder Verzeichnisse umbenennen oder löschen darf, und die Schaltflächen zum Hinzufügen von Netzwerklaufwerken und zum Deinstallieren von Software in der Symbolleiste fehlen.

/SAVE Speichert die Ergebnisse in einer Textdatei, nachdem die Untersuchung abgeschlossen ist, und beendet das Programm. Beispiel:

tsizepro /SAVE C:\Scans\c.txt C:\

/SEARCH öffnet das Fenster zur Dateisuche von TreeSize Professional 3. Wenn ":Start" zu dieser Kommandozeilen Option hinzugefügt wird, wird die Suche unmittelbar gestartet. Es werden dabei dieselben Einstellungen verwendet, wie bei der letzten Benutzung der Dateisuche. Findet TreeSize Pro dagegen den Zusatz ":Internet" bei dieser Option, so startet es die Suche nach temporären Internet Dateien und löscht diese anschließend. Beispiel:

tsizepro /SEARCH:Internet

   TreeSize Professional 3 benutzt die selben Einstellungen wie bei der zuletzt durchgeführten Dateisuche. Sie können jedoch die Suchmuster für die Temporäre Dateisuche mittels der /FILTER Kommandozeilen Option angeben. Tipp: Sie können die Ergebnisse der Dateisuche mit der /SAVE Kommandozeilen-Option in eine Text- oder CSV -Datei speichern.

/TITLE Kann genutzt werden, um den Titel des gedruckten oder exportierten Reports zu ändern und so noch zusätzliche Informationen anzugeben, wenn TreeSize Professional 3 in einer automatisierten Umgebung genutzt wird. Beispiel:

tsizepro /TITLE "Dies ist ein Report von Laufwerk C auf Server3" /PRINT \\Server3\C$

/USERSLIST Diese Option schreibt die Statistik über die Verteilung der Dateigrößen auf die verschiedenen Benutzer des untersuchten Dateisystemzweiges in eine Text- oder CSV-Datei. Das folgende Beispiel untersucht Laufwerk C: und erstellt eine CSV-Datei in C:\Temp mit der Statistik der Benutzer auf diesem Laufwerk:

   tsizepro /USERSLIST C:\temp\C_users.csv C:\

/XML Speichert die Ergebnisse in einer XML-Datei, die später wieder geladen oder für Vergleichszwecke genutzt werden kann.

tsizepro /XML C:\Results\Allusers.xml H:\users\

Directories Am Ende der Kommandozeile können ein oder mehrere Pfade angegeben werden, die TreeSize Professional 3 durchsuchen soll. Die Platzhalter * und ? sind erlaubt. Beispiel:

tsizepro H:\users\A*

Zeitgesteuerte Scans
Wenn Sie Windows 98/ME oder Windows NT4+ mit installiertem Internet Explorer 5 verwenden, können Sie den Ordner 'Geplante Vorgänge' verwenden, um zeitgesteuerte Untersuchungen mit TreeSize Professional 3 durchzuführen. Fügen Sie dazu einfach einen neuen täglichen Task hinzu und wählen Sie TreeSize Professional 3 als auszuführendes Programm aus. Vor dem Fertig stellen wählen Sie noch aus, weitere Eigenschaften des Task einzustellen und fügen die gewünschten Parameter hinter Tsizepro.exe ein.

Wenn Sie Windows NT 4 oder höher verwenden, können Sie das at-Kommando verwenden, um zeitgesteuerte Untersuchungen durchzuführen. Um beispielsweise eine Untersuchung der Laufwerke C: und E: um 3:00 Uhr nachts durchzuführen, müssen Sie folgendes Kommando an der NT Kommandozeile eingeben:

at 03:00 "C:\Programme\JAM Software\TreeSize Professional 2.4\tsizepro.exe" /EXCEL c:\temp\tsp.xls /EXPAND 2 c:\ e:\

Wenn Sie die Ergebnisse der Dateisuche am nächsten Morgen auf dem Monitor in Ihrem Büro sehen wollen, sollten Sie ein Kommando der folgenden. Art verwenden:

at 06:00 /INTERACTIVE "C:\Program Files\JAM Software\TreeSize Professional 2.3\tsizepro.exe" /SEARCH:Start

Weitere Informationen zum at-Kommando finden Sie in der Windows NT Hilfe. Fehler bei der Ausführung werden im Ereignisprotokoll von Windows NT/2000 festgehalten.

Windows Scripting Host
Wenn Sie den Windows Scripting Host verwenden möchte, sieht das Kommando zum Starten von TreeSize Professional 3 wie folgt aus:

Set Shell = CreateObject("WScript.Shell")
Shell.Run """C:\Program Files\TreeSize Professional\tsizepro.exe"" /XML c:\temp\drive_c.xml c:\"


Hinweise zu NTFS

Das Dateisystem NTFS, das unter den Betriebssystemen Windows NT, 2000 und XP benutzt werden kann, bietet einige besondere Funktionen die auch Auswirkungen auf TreeSize haben. Im Folgenden werden wir einige dieser speziellen Fähigkeiten und ihre Auswirkungen auf TreeSize beschreiben.

Access Control Lists (Zugriffskontrolllisten)
Unter Windows NT und seinen Nachfolgern kann ein Benutzer die Zugriffsmöglichkeiten anderer Nutzer auf seine Dateien und Ordner einschränken, indem er Benutzern oder Benutzergruppen bestimmte Rechte wie das Lesen, Schreiben, Löschen oder Ausführen von Dateien gewährt oder verweigert. Auf diesem Weg kann ein Benutzer sogar dem Administrator den Zugriff auf seine Dateien und Ordner verwehren. Wenn ein Administrator im Windows Explorer versucht, auf eine solche Datei oder einen solchen Ordner zuzugreifen, wird eine Fehlermeldung "Zugriff verweigert" angezeigt. TreeSize Professional kann seit V2.4 trotzdem solche Verzeichnisse untersuchen, wenn Sie als Administrator eingeloggt sind, oder als normaler Benutzer, der das Recht hat, Backups durchzuführen. (Diese Einstellung kann bei Windows 2000 unter Systemsteuerung / Verwaltung / Lokale Sicherheitsrichtlinie und bei Windows NT in der Benutzerverwaltung verändert werden.)

Dateibasierte Kompression
NTFS unterstützt die transparente Kompression einzelner Dateien. Derart komprimierte Dateien können gelesen oder geschrieben werden, ohne vorher mit einem externen Programm (de)komprimiert werden zu müssen. Die Dekompression geschieht vielmehr automatisch beim Lesen einer Datei, genauso wie die Kompression beim Schreiben.

Der Platz, den eine komprimierte Datei auf der Festplatte belegt, ist normalerweise geringer als seine eigentliche Größe. Deshalb kann bei komprimierten Verzeichnissen der von TreeSize ermittelte belegte Platz wesentlich kleiner sein als die angezeigte Größe des Verzeichnisses. Der Kompressionsfaktor wird in einer eigenen Spalte der Detailansicht angezeigt. Außerdem können komprimierte Dateien und Ordner in einer anderen Farbe angezeigt werden (diese Funktion kann in den Einstellungen aktiviert werden).

Seit Windows 2000 beherrscht NTFS ein weiteres Konzept, das der dateibasierten Kompression ähnelt: Sparse Files. So genannt werden sehr große Dateien, die aber nur in Teilbereichen Daten enthalten. Da das Betriebssystem für die ungenutzten Teilbereiche keinen Platz auf der Festplatte reservieren muss, braucht die Datei weniger Platz auf der Festplatte als sie eigentlich groß ist. TreeSize behandelt diese Art von Dateien ähnlich wie komprimierte Dateien und berechnet für sie ebenfalls den Kompressionsfaktor.

Reparse Punkte: Mountpoints und symbolische Links
Seit Windows 2000 unterstützt NTFS Mountpoints und symbolische Links. Ein Mountpoint ist ein existierender Pfad, in den ein anderes Laufwerk "eingehängt" werden kann. Unterhalb dieses Mountpoints findet man dann die komplette Verzeichnisstruktur des eingehängten Laufwerks, ein Buchstabe muss dem eingehängten Laufwerk dabei nicht zugeordnet sein. Auf diese Weise lassen sich viele Laufwerke in einem einheitlichen Dateisystembaum zusammenführen. Symbolische Links funktionieren ähnlich: Hat man beispielsweise ein leeres Verzeichnis C:\Dokumente\Bilder, kann man hier einen symbolischen Link zu E:\Pics erstellen. Anwendungen werden dann den Inhalt von E:\Pics unter C:\Dokumente\Bilder sehen.

Wenn die Einstellung "Mountpoints und symbolischen Links folgen" aktiviert ist, berücksichtigt TreeSize den Inhalt dieser Ordner beim Untersuchen von Laufwerken. Da diese aber nicht physisch auf dem untersuchten Laufwerk liegen, kann dies zu irritierenden Ergebnissen führen.

Eine abschließende Bemerkung: Wenn Sie ein NTFS Laufwerk über das Netzwerk untersuchen, kann TreeSize dateibasierte Kompression und Reparse Punkte nur dann handhaben, wenn es unter Windows NT oder seinen Nachfolgern läuft. Das API von Windows 9x kann diese Eigenschaften nicht handhaben, so dass Reparse Punkte und komprimierte Dateien wie normale Dateien erscheinen.


Index

F.A.Q. - Index

· Allgemein / Registrierung

· Hauptprogramm

· Drucken / Export

· Dateisuche


Allgemein / Registrierung

FAQ - Kauf / Registrierung

F: Wie kann ich TreeSize Professional 3 kaufen und wie wird es geliefert?
A: Sie können TreeSize Professional 3 Online unter http://www.jam-software.de/prices.shtml bestellen. Dort finden Sie ebenfalls ein Fax-Bestellformular. Die Bestellungen werden von unserer Bestellabteilung spätestens am nächsten Werktag bearbeitet. Für Firmen ist auch der Kauf auf Rechnung möglich. Wenn Sie den Download für den Bezug der Vollversion auswählen, erhalten Sie die Adresse einer geheimen Webseite, von der Sie die Vollversion herunterladen können. Möchten Sie die Software auf Disk mit gedruckten Handbuch geliefert bekommen, fallen zusätzlich noch 6€ Versandkosten an. Außerdem erhalten Sie noch ein Passwort, der für die Installation benötigt wird.

F: Was ist der Unterschied zwischen der Demoversion und der Vollversion?
A: Die Demoversion erlaubt es Ihnen, unsere Software vor dem Kauf für einen bestimmten Zeitraum zu testen. Die Testphase darf maximal 21 Tage betragen. Darüber hinaus gehende Benutzung der Software ist illegal und verstößt gegen geltendes Recht. Damit unsere Kunden die von uns angebotenen Softwareprodukte in vollem Umfang testen können, enthalten die Demoversionen in der Regel keine signifikanten Einschränkungen. Aber die Software wird sie während der Testphase gelegentlich an den noch nicht vollzogenen Kauf erinnern.

F: Ich habe Ihr Produkt gekauft. Wie kann ich meine Demoversion jetzt freischalten?
A: Sie müssen sich die Vollversion in unserem Kundenbereich http://www.jam-software.de/customers/ herunterladen. Die Zugangsdaten haben Sie per E-Mail oder auf dem Lizenzschreiben erhalten. Falls Sie die Zugangsdaten nicht mehr haben, können Sie sich diese noch einmal an die E-Mail Adresse schicken lassen, die Sie beim Kauf verwendet haben.

F: Sind Updates kostenpflichtig?
A: Updates innerhalb einer Major Version (z.B. 3.x) sind kostenlos. Registrierte Kunden können das Update auf die nächsthöhere MAjor Version zu einem reduzierten Preis (ca. 40% des normalen Preises) auf der Web-Seite für registrierte Kunden erwerben: http://www.jam-software.de/customers/

F: Obwohl ich die Vollversion von TreeSize Professional 3 gekauft habe, wird immer noch "Unregistriert" im Fenstertitel angezeigt. Woran könnte das liegen?
A: Es gibt drei verschiedene Möglichkeiten, warum noch immer "UNREGISTRIERT" im Titel des Fensters erscheint:
1. Sie haben nicht die Vollversion der Software von der Adresse heruntergeladen, die Sie nach dem Kauf erhalten haben.
2. Sie haben versehentlich noch einmal die Demoversion installiert. (Wurden Sie nach einem Passwort gefragt?)
3. Sie haben die Demo- und die Vollversion in verschiedene Verzeichnisse installiert, so dass sich jetzt beide Versionen auf Ihrer Festplatte befinden.

F: Warum verwenden Sie keine Aktivierungscodes, mit der man eine Demo- in einer Vollversion umwandeln kann?
A: Wir verwenden keine Aktivierungscodes, da man diese gewöhnlich sehr einfach im Internet finden kann. Wir arbeiten mit unterschiedlichen Test- und Vollversion. Nach dem Kauf erhalten unsere Kunden eine Diskette oder eine Download Adresse, unter der sie sich die Vollversion herunterladen können. Außerdem erhalten Sie ein Passwort, das für die Installation benötigt wird. Beides sollte an einem sicheren Platz aufbewahrt werden.

F: Gibt es die Möglichkeit einer "Silent" Installation?
A: Wenn Sie die Installationsdatei mit den Kommandozeilen Parametern /SILENT und /PASSWORD=InstallPasswort aufrufen, wird die Software ohne irgendwelche Nachfragen mit den Default-Werten installiert. Ersetzen Sie bitte InstallPasswort mit dem Passwort, dass Ihnen bei der Registrierung mitgeteilt worden ist. Die Verwendung von /VERYSILENT anstatt von /SILENT blendet auch jegliches visuelles Feedback aus. Die Option /DIR="x:\dirname" kann verwendet werden, um ein alternatives Zielverzeichnis anzugeben.


Hauptprogramm

FAQ - Hauptprogramm

F: Warum ist der belegte Platz, den Windows in den Eigenschaften des Laufwerks anzeigt, größer als der von TreeSize Professional 3 angezeigte?
A: Der Windows Explorer zeigt den physisch auf dem Laufwerk belegten Platz an während TreeSize den Platz anzeigt, den alle Dateien und Verzeichnisse zusammen unterhalb eines bestimmten Pfades belegen. Über den Platz für Dateien und Verzeichnisse hinaus wird auf einem Laufwerk noch zusätzlicher Platz zum Ablegen von Verwaltungsinformationen benötigt, wie z.B. die Dateibelegungstabelle (FAT) oder der Boot Sektor. Hierfür werden üblicherweise rund 0,5 - 2% des Platzes einer Partition benötigt.
Eine andere Möglichkeit für die Abweichung kann die Verwendung von Software RAID sein, wie es beispielsweise Windows NT/2000 bietet. RAID verteilt die Daten auf mehrere Festplatten, die im System aber wie ein einzelnes Laufwerk erscheinen. Häufig werden die Daten redundant gespeichert, so dass der Ausfall einer einzelnen Festplatte zu keinem Datenverlust führt. Allerdings benötigt das Speichern der redundanten Informationen zusätzlichen Platz auf den Festplatten.
Eine weitere Möglichkeit für die Abweichung besteht dann, wenn ein Netzwerklaufwerk lediglich mit einem Unterverzeichnis eines Serverlaufwerks verbunden ist. Der von TreeSize angezeigte belegte Platz kann dann niedriger sein als der physisch auf dem Laufwerk belegte Platz, da TreeSize lediglich den über das Netzlaufwerk zur Verfügung gestellten Teilbereich des Laufwerks untersuchen kann.
Durch fehlende Leserechte kann es ebenfalls dazu kommen, dass TreeSize bestimme Bereiche der Festplatte nicht lesen kann, so dass deren Größe am Ende in der Summe fehlt.

F: Warum zeigt TreeSize für einige Verzeichnisse ein Datum in der Zukunft an?
A: Das Datum der letzten Änderung und des letzten Zugriffs, das TreeSize Professional 3 für einen Ordner anzeigt, ist das "späteste" Datum aller Dateien in diesem Ordner und seinen Unterordnern. Wahrscheinlich gibt es also innerhalb des betroffenen Verzeichniszweiges eine oder mehre Dateien mit einem Datum in der Zukunft. Diese sind häufig durch Jahr-2000 Tests oder durch Client PCs mit einem falschen Systemdatum entstanden. Der Windows Explorer berücksichtigt beim Berechnen des Datums des letzten Zugriffs nur die Dateien, die sich unmittelbar in diesem Ordner befinden. Wird also ein Unterordner geändert, so führt dies (unkorrekterweise) nicht zu einer Änderung des Datums des übergeordneten Verzeichnisses.

F: Warum haben alle Dateien auf meiner Festplatte das gleiche Datum für den letzten Zugriff?
A: Windows aktualisiert das Datum des letzten Zugriffs jedes Mal, wenn eine Anwendung (lesend) auf eine Datei zugreift. Viele Backup-Programme und Viren-Scanner greifen regelmäßig oder täglich auf viele oder alle Teile der Festplatte zu und verändern so das Datum des letzten Zugriffs.

F: Warum bezieht TreeSize Professional 3 nicht das Laufwerk in seine Berechnungen mit ein, das ich über die Datenträgerverwaltung von Windows 2000/XP in einem NTFS-Ordner bereitgestellt habe?
A: Durch Einschalten der Option "Mountpoints und symbolischen Links folgen" in den Einstellungen von TreeSize Professional 3 können Sie festlegen, ob Mountpoints und symbolischen Links gefolgt werden soll oder diese nicht in die Berechnungen einfließen sollen.

F: Das Untersuchen von Serverlaufwerken über das Netzwerk ist sehr langsam. Kann man dies beschleunigen?
A: Das Untersuchen von Laufwerken über das Netzwerk ist normalerweise wesentlich langsamer als bei lokalen Laufwerken, da bei Zugriffen über das Netzwerk die Bandbreite geringer und der Overhead höher ist. Serverlaufwerke sind außerdem meist wesentlich größer und enthalten mehr Dateien. Sie können die Scans aber z.B. auf dem Server selbst durchführen oder mit Hilfe der Kommandozeilen Parameter nächtliche Untersuchungen durchführen.

F: Kann TreeSize Professional 3 die Anzeige von Verzeichnissen unterdrücken, die eine bestimmte Größe unterschreiten?
A: Im Kontextmenü des obersten Ordners gibt es eine Funktion, mit der alle Ordner aus der Anzeige entfernen werden können, die eine bestimmte Größe unterschreiten. Zur Verwendung klicken Sie bitte mit der rechten Maustaste auf das Wurzelverzeichnis (oder verwenden Sie das Untermenü "Zweig" aus dem Hauptmenü "Datei"), wählen dann "Einblenden" und dann "Entferne Ordner <XX MB".

F: Kann auch der Freie Platz eines Laufwerks im Tortendiagramm angezeigt werden?
A: Wenn die Wurzel des untersuchten Laufwerks ausgewählt ist, wird auch der freie Platz des Laufwerks im Tortendiagramm angezeigt, sofern die entsprechende Option im Kontextmenü des Tortendiagramms aktivert ist.

F: Kann ich ein Netzwerklaufwerk auch untersuchen, ohne es mit einem Laufwerksbuchstaben zu verbinden?
A: Ja. Sie können UNC Namen der Art \\SERVERNAME\Share verwenden, um Netzwerklaufwerke anzusprechen. Geben Sie diese einfach in der Dropdown Box in der Symbolleiste von TreeSize ein. Sie können UNC Namen auch als Kommandozeilen Parameter verwenden.

F: Ich würde gerne jedes mal eine bestimmte Menge von Laufwerken untersuchen, wenn TreeSize startet. Ist das möglich?
A: Sie können einfach eine Verknüpfung zu Tsizepro.exe auf Ihrem Desktop oder im Start-Menü erstellen und die Laufwerke durch Leerzeichen getrennt zur Kommandozeile hinzufügen. Bitte beachten Sie auch das Kapitel "Kommandozeilen Parameter" für weitergehende Informationen.

F: Wie kann ich einen Scan auf nur einen betimmten Benutzer einschränken?
A: Zuerst versichern Sie sich bitte, dass die Option "Gruppieren nach Benutzern" in den Optinen von TreeSize Professional 3. Nachdem der Scan beendet ist, klicken Sie bitte auf dem Reiter "Benutzer" mit der rechten Maustaste auf den betreffenden Benutzer und wählen dort "Auf diesen Benutzer einschränken" aus.

F: Warum werden auf einem Novell Netware Laufwerk komprimierte Dateien als unkomprimierte angezeigt?
A: Prinzipiell können Sie auch Novell Laufwerke unterscuhen, die als Netzwerklaufwerk unter Windows Freigabe erreichbar sind. Leider liefert der Netware Client für Windows keine Informationen über Kompression und Besitzer durch die normalen Windows API-Funktionen. Daher müssen Entwickler für Netware zusätzlich spezielle Unterstützung einbauen. Wir werden diese in einer späteren Funktion von TreeSize Professional 3 nachliefern. Alle anderen Funktionen stehen jedoch auch auf Netware-Laufwerken uneingeschränkt zur Verfügung.

F: Beim Untersuchen eines Laufwerks, das Macintosh Dateien enthält, erhalte ich seltsame Fehlermeldungen. Warum?
A: Unter MacOS dürfen Datei- und Verzeichnisnamen Zeichen enthalten, die unter Windows unzulässig sind (z.B. /, |, <, >, ?) oder die im normalen Windows Zeichensatz nicht enthalten sind. Auf diese Dateien können normale Windows Anwendungen nicht zugreifen, TreeSize verwendet in diesem Fall den 8+3 DOS Namen der Datei oder des Verzeichnisses. Die Anzeige von Fehlermeldungen dieser Art können im Optionen-Dialog abgeschaltet werden.

F: Warum bezieht TreeSize Professional 3 nicht das Laufwerk mit in seine Berechnungen ein, das mit der Datenträgerverwaltung von Windows auf ein bestimmtes Verzeichnis abgebildet wurde?
A: Durch Umschalten der Option "Mountpoints und symbolischen Links folgen" in den Optionen kann festgelegt werden, ob TreeSize Professional 3 Mount-Punkten und symbolischen Links folgt oder diese nicht in die Berechnungen einbezieht.

F: Ist es mit TreeSize Professional 3 möglich, nach Dateiendungen zu suchen?
A: Sie können beispielsweise in den Optionen einen Filter für einen Scan-Vorgang definieren, indem Sie Suchmuster der Art *.BMP zum Textfeld hinzufügen. Eine zweite Möglichkeit besteht darin, die Funktion "Gruppieren nach Dateitypen" in den Optionen zu aktivieren. Diese wird eine detaillierte Statistik für die Dateitypen in jedem Verzeichnis erstellen und sie werden die Möglichkeit haben, die Anzeige der Verzeichnisgrößen im Baum auf eine bestimmte Dateiendung einzuschränken. Eine dritte Möglichkeit besteht in der Verwendung der Dateisuche für temporäre Dateien, indem eigene Suchmuster auf dem Reiter "Temporäre Dateien" hinzugefügt werden. Unser neues Produkt SpaceObServer verfügt noch über weiter gehende und flexiblere Reportfunktionen.

F: Der verschwendete Platz, der von TreeSize angezeigt wird, ist bei mir extrem hoch. Wie kann ich diesen reduzieren?
A: Wahrscheinlich verwenden Sie das FAT Dateisystem, das durch seine großen Blöcke meist eine große Menge an verschwendetem Platz verursacht. Bitte lesen Sie das Kapitel "Verschwendeter Platz" um zu verstehen, was verschwendeter Platz ist und wie man ihn reduzieren kann.


Drucken / Export

FAQ - Drucken / Export

F: Ich würde gerne eine komplette Liste all meiner Dateien auf der Festplatte drucken. Warum unterstützt TreeSize Professional 3 dies nicht?
A: Eine normale Windows 2000 Installation umfasst alleine schon 6000 bis 10000 Dateien im Windows Verzeichnis. Das Ausdrucken dieses Verzeichnisbaumes würde schon 90 - 130 Blatt Papier erfordern, für die gesamte Festplatte wäre noch wesentlich mehr erforderlich. Deshalb unterstützt TreeSize nur das Drucken des Inhalts des selektierten Verzeichnisses. Darüberhinaus kann aber eine komplette Liste aller Dateien im untersuchten Verzeichniszweig in die Zwischenablage kopiert werden. Diese kann dann in einer Tabellenkalkulation oder einer Datenbank weiterverarbeitet oder gedruckt werden.

Q: Wie kann ich die Spalten auswählen, die in einem gedruckten Report oder einer exportierten Excel-Datei erscheinen?
A: Unter Ansicht / Optionen / Spalten können die gewünschten Spalten ausgewählt werden, nachdem Sie in der Dropdown Box am oberen Rand ein Export-Medium ausgewählt haben.


Dateisuche

FAQ - Dateisuche

F: Wie kann ich nach Dateien vom Typ XYZ suchen?
A: Die Windows Dateisuche erfüllt diese Aufgabe bereits relativ gut. TreeSize Professional 3 wurde primär zum Auffinden alter und überflüssiger Dateien konzipiert, dennoch gibt es natürlich Möglichkeiten bestimmte Dateitypen zu finden. Sie können beispielsweise nur die Suche nach Temporären Dateien aktivieren, dort deaktivieren Sie alle Suchmuster und fügen das gewünschte hinzu. Weitere Möglichkeit: Im Hauptprogramm setzen Sie in den Optionen einen Filter. Der sorgt dafür, dass beim Bestimmen der Verzeichnisgrößen nur zum Filter passende Dateien berücksichtigt werden. Das Ergebnis verschafft einen recht guten Überblick über die Verteilung dieses Dateityps. Unser Produkt SpaceObServer, das die Daten über die beobachteten Dateisysteme in einer SQL-Datenbank speichert, hat darüber hinaus noch schnellere und flexiblere Reporting Funktionen.

F: Warum enthält TreeSize Professional 3 keine Suche für doppelte Dateien?
A: Wir haben mehrere Tests mit existierenden Tools zur Suche nach doppelten Dateien durchgeführt. Die Menge an Festplattenplatz, die zurückgewonnen werden konnte, war jeweils extrem gering, da nur wenige der angezeigten Dateien echte doppelte Dateien waren, die problemlos gelöscht werden konnten. Der Zeitaufwand, der zur Durcharbeitung der Liste benötigt wurde, war sehr groß. Und die Gefahr, das ein unerfahrener Benutzer in Unkenntnis eine notwendige Datei löscht, war ebenfalls groß.

F: Ist es möglich gleichzeitig mehrere oder alle Dateien in den Ergebnislisten der Dateisuche zu markieren?
A: Es können wie in anderen Anwendungen üblich mehre Einträge mit der linken Maustaste ausgewählt werden, wenn gleichzeitig die Strg- oder Umschalttaste gleichzeitig gedrückt wird. Durch Drücken von Strg+A werden alle Einträge der Liste markiert. Nun können mit dem Menüpunkt "Markieren" aus dem Kontextmenü alle ausgewählten Dateien markiert werden. Aufeinander folgende Einträge können übrigens auch durch mehrmaliges Drücken der Leertaste markiert werden.


Optionen Dialog

Der Optionen Dialog wird durch den entsprechenden Menüpunkt im "Ansicht"-Menü oder über die Symbolleiste aktiviert. Er erlaubt die Festlegung von Einstellungen für die Darstellung und den Untersuchungsvorgang (Scan) und besteht aus folgenden Reitern:

· Ansicht
· Untersuchen
· Filtern
· Spalten


Reiter "Ansicht"

Optionen Dialog - Reiter "Ansicht"

Andere Farbe für komprimierte Dateien und Ordner Ist diese Option aktiviert, werden komprimierte Dateien auf einem NTFS Laufwerk in blauer Farbe angezeigt. Verzeichnisse, die nur teilweise komprimiert sind, werden dunkelblau angezeigt, Dateien und Verzeichnisse, die komplett komprimiert sind, erscheinen hellblau. Für weitere Informationen über dateibasierte Komprimierung lesen Sie bitte das Kapitel "Hinweise zu NTFS".

Zeige Dateien Wenn diese Option ausgewählt ist, werden die Dateien eines Ordners in der Verzeichnisstruktur summiert in einem Objekt angezeigt. Außerdem werden die Dateien in der Detaildarstellung einzeln angezeigt.

Symbolleiste für Diagramme Zeigt eine zusätzliche Symbolleiste zur Manipulation der Diagramme an.

Rechte Seite während des Scannens aktualisieren Ist diese Option aktiviert, so aktualisiert TreeSize Pro die rechte Seite des Fensters von Zeit zu Zeit. Dies erlaubt es z.B. die Balkendiagramme während des Scans wachsen zu sehen. Verwenden Sie den Schieber um das Intervall einzustellen.

Dezimalstellen Anzahl der Dezimalstellen, die TreeSize bei der Darstellung von Werten nach dem Dezimalpunkt verwenden soll.

Einträge in Liste zuletzt untersuchter Dateien Im Datei-Menü und in der Box zum Auswählen der Laufwerke finden Sie eine Liste mit den zuletzt untersuchten Ordnern und Laufwerken. Hier können Sie einstellen, wie viele Einträge diese Liste maximal haben soll.

Fettdruck Faktor Wenn die Größe eines Verzeichnisses größer als der angegebene Wert oder Prozentsatz des gesamten untersuchten Verzeichnisses ist, dann wird der Verzeichnisname in Fettschrift dargestellt. Dies ermöglicht es Ihnen schnell die besonders großen Verzeichnisse zu erkennen. Wenn Sie keine fett gedruckten Verzeichnisnamen wünschen, wählen Sie hier 100% aus. Sie können diese Einstellung auch für den Report-Druck verwenden, indem Sie die darunter liegende Checkbox aktivieren.


Reiter "Untersuchen"

Optionen Dialog - Reiter "Untersuchen"

Wenn Sie Veränderungen auf der Seite 'Untersuchen' vornehmen, ist ein erneutes Einlesen aller aufgeführten Verzeichnisse und Laufwerke erforderlich. Diese Einstellungen werden beim Beenden von TreeSize Professional nicht gespeichert, um falsche Ergebnisse bei der nächsten Benutzung zu vermeiden. Es stehen folgende Einstellungen zur Auswahl:

Mountpoints und symbolischen Links folgen Diese Option wirkt sich nur auf NTFS Laufwerken aus und entscheidet darüber, ob TreeSize Pro Mountpoints und symbolischen Links folgen soll oder nicht. Weitere Informationen hierzu gibt es im Kapitel "Hinweise zu NTFS".

Zeige Fehlermeldungen Hier können Sie festlegen, ob TreeSize Professional Fehlermeldungen während der Untersuchung eines Ordners oder Laufwerks anzeigen soll (und dabei anhalten soll) oder nicht. Wenn Sie beispielsweise ein Netzwerklaufwerk auf einem NT Server untersuchen, auf dem Sie für einige Verzeichnisse keine Leserechte besitzen, wird jeweils eine Fehlermeldung angezeigt. Wenn die Untersuchung nicht durch diese Meldungen unterbrochen werden soll, deaktivieren Sie diese Option.

Gruppieren nach Benutzernamen Ist diese Option aktivert, wird Benutzernamenalle Daten eines Verzeichnisses nach Benutzernamen gruppieren. Die Ergebnisse können auf dem Reiter "Benutzer" betrachtet werden. Diese Option verschafft Ihnen einen guten Überblick darüber, welcher User in welchem Verzeichnis wie viel Platz belegt. Da für jede Datei beim System der Besitzer erfragt werden muss, verlangsamt das Einschalten dieser Funktion einen Scan signifikant.

Gruppieren nach Dateiendungen Ist diese Option aktiviert, so werden die gesammelten Daten pro Verzeichnis zusätzlich nach der Dateiendung gruppiert. Die Ergebnisse können auf dem Reiter "Dateitypen" betrachtet werden.

Benutzerdefinierte Blockgröße Verwenden Sie diese Einstellung, um sich ein Bild davon zu machen, wie Ihr Laufwerk mit einer anderen Blockgröße aussehen würde. Die Blockgröße hat Einfluss auf den belegten und den verschwendeten Platz Ihrer Verzeichnisse. Diese Option speichert TreeSize Professional 3 nach dem Beenden nicht ab, um bei der nächsten Benutzung falsche Ergebnisse zu vermeiden.


Reiter "Filtern"

Optionen Dialog - Reiter "Filtern"

Der Reiter "Filtern" erlaubt, bestimmte Dateien für die Scans ein- oder auszuschließen.

Dateitypen Wenn Sie nur Informationen über bestimmte Dateitypen haben wollen, können Sie hier einen Filter angeben. Es können auch mehrere Filter durch Leerzeichen getrennt angegeben werden. Wenn Sie beispielsweise nur Informationen über Programmdateien haben wollen, geben Sie hier "*.exe *.dll" an. Wenn Sie alle Dateien mit einbeziehen möchten, geben Sie einfach "*" an. Diese Option speichert TreeSize Professional 3 nach dem Beenden nicht ab, um bei der nächsten Benutzung falsche Ergebnisse zu vermeiden. Wenn sie öfter einen Scan für nur bestimmte Dateitypen durchführen, können Sie hierfür eine eigene Verknüpfung erzeugen für diese entsprechende Kommandozeilen Parameter festlegen.

Nur Dateien mit Erstellungsdatum innerhalb XX Tage Diese Option bezieht nur Dateien mit in einen Scan ein, die innerhalb der angegebenen Anzahl von Tagen neu erstellt worden sind. Mit dieser Option können Sie sich einen guten Überblick über stark wachsende Verzeichnisse verschaffen.

Nur Dateien mit gesetztem Archiv-Attribut einbeziehen Diese Option ist nützlich, wenn Sie wissen wollen, wie groß Backups für ein bestimmtes Verzeichnis werden.

Ausschlusskriterien Wenn bestimmte Dateien oder Verzeichnisse vom Scan ausgeschlossen werden sollen, können Sie hier ein entsprechendes Muster der Art "Windows" oder "*.tmp" hinzufügen. Alle Dateien und Verzeichnisse, die auf eines der angegebenen Muster passen, werden dann nicht in den Scan einbezogen.


Reiter "Spalten / Export"

Optionen Dialog - Reiter "Spalten / Export"

Auf der Seite 'Spalten / Export' können Sie auswählen, welche Spalten sichtbar sein sollen. Dies kann separat für jedes "Ausgabe-Medium" (Detailansicht, Excel Export, Gedruckter Report, Textdatei etc.) festgelegt werden , in dem der entsprechende Eintrag in der Auswahlbox im oberen Bereich ausgewählt wird. Die folgenden Spalten stehen zur Verfügung:

Name Der Name der Datei oder des Ordners

Absoluter Pfad Der absolute Pfad inklusive des Namens des Objekts.

Größe Die Größe des Objekts.

Belegt Der Platz, den das Objekt aktuell auf der Platte belegt (siehe auch: Verschwendeter Platz).

Dateien Die Anzahl der Dateien in einem Ordner.

Ordner Die Anzahl der Unterordner in einem Ordner.

Verschwendet Der Platz, der durch das Dateisystem verschwendet wird (siehe auch: Verschwendeter Platz).

Prozent Der Platz, den ein Objekt relativ zu dem Ordner belegt, in dem es gespeichert ist.

Letzte Änderung Das Datum der letzten Änderung eines Objekts. TreeSize Professional 3 berechnet das Datum der letzten Änderung und des letzten Zugriffs für Ordner exakter als dies der Windows Explorer tut. Daher können sich die angezeigten Werte von denen des Windows Explorer unterscheiden.

Letzter Zugriff Das Datum, an dem zuletzt auf ein Objekt zugegriffen worden ist.

Kompr. Die Größe in Prozent, um die das Objekt durch die eingebaute Kompression des Dateisystems komprimiert werden konnte. (siehe auch: Hinweise zu NTFS).

Besitzer Der Name des Benutzers, der für das Objekt als Besitzer eingetragen ist.

CD-ROM Größe Der Platz, den das Objekt auf einer CD-ROM belegen würde.

Aktuelles Datum Das aktuelle Datum. Diese Spalte kann nützlich sein, wenn die gesammelten automatisiert weiter verarbeitet werden sollen, z.B. in einer Datenbank.

Attribute Die Datei-Attribute Schreibgeschützt (R), Versteckt (H), System (S), Archiv (A).

Dateityp Der Typ des Objekts, z.B. "Textdatei".

Verzeichnistiefe Die Ebene, auf der sich das Objekt im Dateisystem Baum befindet. Diese Spalte kann nützlich sein, wenn die gesammelten automatisiert weiter verarbeitet werden sollen, z.B. in einer Datenbank.

Erstellungsdatum Das Datum, an dem das Objekt erstellt worden ist.

Pfad (ohne Dateiname) Der absolute Pfad des Verzeichnisses, in dem sich das Objekt befindet.

Durchschn. Dateigröße Die durchschnittliche Größe der Dateien in einem Ordner.

Berechtigungen Die Zugriffsberechtigungen für das Objekt in dem Format: Benutzername1: +/-R +/-W +/-X Benutzername2: ... wobei ein gewährtes Recht mit "+" und ein verwehrtes Recht mit "-" gekennzeichnet wird.

Dateiversion Die Versionsnummer die in EXE, DLL, OCX und ähnlichen, binären Dateien meist enthalten ist.

Titel des Scans Standardmäßig der Titel eines Scans. Er kann mit Hilfe von "Titel angeben" im Datei Menü geändert werden. Dies kann beispielsweise bei der Archivierung der gesammelten Daten nützlich sein.

Die angezeigten Spalten in der Detail-Liste von TreeSize Professional 3 können schnell über das Kontextmenü des Listenkopfes ausgewählt werden:

Export

Kompletter Baum Der komplette Dateisystembaum wird exportiert.

Nur aufgeklappte Ordner Es werden nur die im linken Teil des Fensters aufgeklappten Teile des Dateisystembaums exportiert.

Kopfzeile Mit dieser Option können Sie steuern, ob beim Export eine Kopfzeile mit den Namen der Spalten erzeugt werden soll.

Standard-Exportdatei Hier können Sie einstellen, in welche Excel-Datei standardmäßig die Daten geschrieben werden sollen.


Datei Menü

Das Datei Menü erlaubt Ihnen Verzeichnisse zum Untersuchen auszusuchen, untersuchte Verzeichnisse aus dem Fenster zu entfernen und die gesammelten Daten zu exportieren oder zu drucken:

Verzeichnis auswählen Zeigt einen Dialog zum Auswählen eines Verzeichnisses an.

XML-Report öffnen Öffnet eine XML-Datei, der durch TreeSize Professional 3 zuvor gespeichert worden ist. Auf diese Weise können Sie frühere Scan-Ergebnisse betrachten, ohne einen neuen Scan durchführen zu müssen.

Als XML-Report speichern Speichert die gesammelten Daten des aktuellen Verzeichniszweiges in eine XML-Datei, die später wieder mit TreeSize Professional 3 geöffnet werden oder zu Vergleichszwecken genutzt werden kann. TreeSize Professional 3 wird mit einer XSLT-Datei ausgeliefert, die die Daten ein solchen XML Datei für die Darstellung in XSLT-fähigen Browser konvertiert (z.B. Firefox >V1.0 oder Internet Explorer >V5.5).

Mit XML-Report vergleichen Lädt eine gespeicherte XML-Datei und vergleicht sie mit den aktuellen Daten durch Differenzbildung der alten Daten mit den aktuellen. Nach der Differenzbildung haben unverändert große Verzeichnisse die Größe 0. Gewachsene Verzeichnisse eine positive Größe und werden in roter Farbe dargestellt. In der Größe reduzierte Verzeichnise haben negative Werte und werden in grüner Farbe dargestellt.

Export Siehe Kapitel Export

Titel angeben Hier können Sie einen Titel für den gerade aktiven Verzeichniszweig angeben. Dieser Titel wird beim Exportieren oder Drucken des Verzeichniszweigs verwendet. Standardmäßig besteht der Titel aus dem Pfad des untersuchten Ordners und dem Namen des Laufwerks.

Drucke Bericht Druckt einen detaillierten Bericht für das aktive Verzeichnis (siehe unter Drucken).

Bericht für alle Drucken Druckt einen Bericht für alle untersuchten Laufwerke und Ordner im linken Bereich des Fensters.

Drucke Diagramm Druckt das gerade angezeigte Diagramm (siehe unter Diagramme).

Drucke Ordnerinhalt Druckt eine Liste aller Objekte im gerade ausgewählten Ordner, mit Größe, Datum, etc.

Seite einrichten Zeigt den Dialog zum Einrichten der Seite an, in dem Sie Papiergröße und Ränder für den Druck einstellen können.

Drucker einrichten Zeigt den Dialog zum Auswählen und Einrichten des Druckers.

Beenden Schließt die Anwendung.


Export Untermenü

Das Untermenü "Export" erlaubt den Export gesammelter Daten auf verschiedenen Wegen. Die Art der Daten (Spalten), die exportiert werden sollen, können auf dem Reiter "Spalten" in den Einstellungen festgelegt werden. Für alle Wege des Exports gilt, dass nur die Daten solcher Verzeichnisse exportiert werden, die im linken Teil des Hauptfensters sichtbar (expandiert) sind. So können Sie die Menge der exportierten Daten entweder manuell, oder mit Hilfe des Kontextmenüs kontrollieren. Diese Einstellung kann ebenfalls in den Optionen verändert werden.

Speichern unter Speichert die gesammelten Daten in eine Textdatei (durch Tabulatoren getrennt). Es werden wiederum nur die Verzeichnisse exportiert, die im Verzeichnisbaum auch eingeblendet sind. Wählen Sie 'Alles einblenden' aus dem Kontextmenü um eine komplette Liste zu erhalten.

Speichern als HTML Speichert die Ergebnisse in eine HTML Datei, die dann mit jedem Browser angeschaut werden kann. Es werden nur die Ergebnisse der Dateien exportiert, die im Verzeichnisbaum auch eingeblendet sind. Wird gerade ein Diagramm angezeigt, so wird dieses in den oberen Bereich der HTML-Datei eingebettet.

Exportieren nach Excel Exportiert die gesammelten Daten nach MS Excel. Es werden wiederum nur die Verzeichnisse exportiert, die im Verzeichnisbaum auch eingeblendet sind. Wählen Sie 'Alles einblenden' aus dem Kontextmenü um eine komplette Liste zu erhalten.

Kopiere gesammelte Daten Kopiert die gesammelten Daten in die Zwischenablage. Es werden nur die Verzeichnisse exportiert, die im Verzeichnisbaum auch eingeblendet sind. Wählen Sie 'Alles einblenden' aus dem Kontextmenü um eine komplette Liste zu erhalten.

Als E-Mail senden Sendet die aktuellen Daten als E-Mail über die MAPI-Schnittstelle von Windows.

Rohdaten verwenden Das Aktivieren dieser Option bewirkt, dass Daten nicht formatiert (z.B. 10,2 MB) sondern als reine Zahlen gespeichert werden (z.B. 10695475). Dies kann die Nachbearbeitung der Daten vereinfachen.

Einstellen Öffnet den Optionen Dialog, mit dem die Spalten für den Export ausgewählt werden können.

Kopiere Dateiliste Kopiert eine komplette Liste aller Dateien in dem untersuchten Ordner (und allen Unterordnern) in die Zwischenablage. Sie können diese Liste in Ihre Tabellenkalkulation einfügen oder mit einer Datenbank weiterverarbeiten.


Zweig Menü

Das Hauptmenü hat ein Menü "Zweig", das alle Aktionen zusammenfasst, die auf einen kompletten Scan bzw. Zweig angewendet werden können.

Aktualisieren Führt den ausgewählten Scan noch einmal durch.

Automatsich Aktualisieren Ermöglicht das Ein- und Ausschalten automatischer Updates für den ausgewählten Scan. Wenn automatische Updates eingeschaltet sind, wertet TreeSize Professional 3 die Windows Meldungen über Änderungen im Dateisystem aus und aktualisiert die betroffenen Ordner. Es aktualisiert die Größe eines Ordners ebenfalls, wenn dieser auf dem Reiter "Details" aufgelistet wird. Möchten Sie, dass sich nach Abschluss des Scans die Informationen über die Ordnergrößen nicht mehr ändern, sollten Sie die automatischen Updates deaktivieren.

Einblenden Das Untermenü "Einblenden" entspricht dem im Kontextmenü.

Aus TreeSize entfernen Entfernt den ausgewählten Scan aus der Ansicht von TreeSize Professional 3.


Ansicht Menü

Sie können verschiedene Arten von Ansichten innerhalb von TreeSize Professional wählen:

Größe Zeigt die Größe eines Ordners inklusive aller Unterordner an.

Belegter Platz Zeigt an, wie viel Platz der Ordner tatsächlich auf dem Laufwerk belegt.

Prozent Zeigt den Anteil jedes Verzeichnisses an seinem übergeordneten Verzeichnis in Prozent an.

Verschwendeter Platz Zeigt den durch das Dateisystem verschwendeten Platz an, der durch das Speichern dieses Ordners verloren gegangen ist.

CD-ROM Blockgröße Zeigt an, wie viel Platz ein Ordner auf einer CD-ROM belegen würde.

Mit den darauf folgenden Menüpunkten können Sie auswählen, was in der rechten Hälfte des Fensters von TreeSize Professional angezeigt werden soll:

Balkendiagramm Zeigt ein Balkendiagramm auf der rechten Seite des Fensters an. Jeder Balken zeigt die Größe und den verschwendeten Platz (die zusammen den belegten Platz bilden) eines Unterverzeichnisses an.

Tortendiagramm Zeigt ein Tortendiagramm in der rechten Hälfte des Fensters an. Die dargestellten Werte hängen von dem gerade ausgewählten Modus (Größe, belegter Platz, Prozent, etc.) ab.

Details Zeigt eine Liste aller Objekte im gerade ausgewählten Ordner an. Für jedes Objekt werden zahlreiche Details wie die Größe, der belegte Platz, der verschwendete Platz, die Anzahl der enthaltenen Objekte, der prozentuale Anteil am übergeordneten Ordner und das Datum des letzten Zugriffs und der letzten Änderung angezeigt. Sie können in den Optionen einzelne Spalten ausblenden.

Die Art, in der TreeSize Größenangaben darstellt, können mit den folgenden Menüpunkten oder den entsprechenden Schaltflächen auf der Symbolleiste verändert werden. Die Anzahl der Nachkommastellen kann in den Einstellungen angepasst werden.

Werte als KB Alle Größenangaben werden in KB angezeigt

Werte als MB Alle Größenangaben werden in MB angezeigt.

Werte als GB Alle Größenangaben werden in GB angezeigt.

Gemischte Größenangaben Auf Basis der Größe des anzuzeigenden Wertes wird automatisch eine passende Einheit ausgewählt.

Weiterhin können Sie im Ansicht Menü das Fenster zur Dateisuche und den Einstellungsdialog einblenden.

Optionen Zeigt den Dialog mit den Einstellungen von TreeSize Professional an.


Sortieren Menü

Sortieren nach Größe Hierbei werden die größten Verzeichnisse zuerst aufgelistet

Sortieren nach Name Hierbei werden die Verzeichnisse in alphabetischer Reihenfolge aufgelistet.

Aus Es wird keine Sortierung durchgeführt. Dies kann nützlich sein, wenn man sehr große Verzeichnisse untersucht. So kann man sich Teilergebnisse anschauen, ohne dass Verzeichnisse ständig ihre Position wechseln.


Tools Menü

Alle aktualisieren Aktualisiert die Ergebnisse für alle gerade angezeigten Verzeichnisse. Dieser Vorgang kann unter Umständen längere Zeit dauern. Ein einzelnes Verzeichnis können Sie aktualisieren, indem Sie den entsprechenden Menüpunkt aus dem Kontextmenü dieses Ordners auswählen oder F5 drücken.

Dateisuche Zeigt das Fenster zur Dateisuche an, mit dem Sie nach alten, besonders großen oder überflüssigen temporären Dateien suchen können.

Software Hinzufügen / Entfernen Öffnet den Dialog aus der Systemsteuerung, mit dem Software hinzugefügt oder entfernt werden kann.

Netzwerklaufwerk verbinden Öffnet ein Fenster, das das Verbinden eines Netzwerklaufwerks mit einem Laufwerksbuchstaben erlaubt. Es können aber auch UNC-Pfade der Form \\Host\Share in die Laufwerksbox links oben eingegeben werden.


Kontextmenüs

Dateisystem-Baum
Wenn Sie mit der rechten Maustaste auf ein Verzeichnis klicken, zeigt Ihnen TreeSize Professional das Kontextmenü des Explorer an. Außerdem finden Sie noch folgende Menüpunkte im TreeSize Untermenü:

Alles einblenden Blendet alle Verzeichnisse unterhalb dieses Ordners ein.

Alles ausblenden Blendet alle Verzeichnisse unterhalb dieses Ordners aus.

Zweig aktualisieren Aktualisiert nur die Daten im Verzeichniszweig unterhalb dieses Ordners. Dies ist wesentlich schneller, als das gesamte untersuchte Verzeichnis erneut einzulesen.

Aus TreeSize entfernen (temporär) Hiermit kann ein Verzeichnis aus dem Baum und aus den Berechnungen von TreeSize entfernt werden, das Verzeichnis wird jedoch nicht physikalisch vom Laufwerk gelöscht und erscheint daher beim nächsten Durchlauf wieder.

Für den obersten Ordner wird ein anderes Kontextmenü mit besonderen Funktionen angezeigt. Es sieht folgendermaßen aus:

Bis Ebene X Blendet alle Verzeichnisse unterhalb des aktiven Ordners bis zu einer bestimmten Tiefe (1-4) ein.

Ordner einblenden über Blendet alle Ordner ein, die größer als die angegebene Größe sind.

Entferne Ordner <xxx MB Entfernt alle Ordner aus der Ansicht, die kleiner als die angegebene Größe sind.

Größe festlegen Legt die Grenzgröße für die beiden vorangegangenen Operationen fest.

Aus TreeSize entfernen Entfernt den Order aus dem Fenster von TreeSize Professional.

Aktualisieren Liest diesen Verzeichniszweig erneut ein.

Details-Liste
The Details-Liste zeigt bei einem Rechts-Klick auf ein Objekt das Kontextmenü des Windows Explorer an. Zusätzlich existiert ein Untermenü mit dem Namen "TREESIZE" das alle verfügbaren Information des ausgewählten Objekts anzeigt. Darin eingeschlossen sind auch die Spalten, die momentan nicht aktiviert sind. Dieses Untermenü kann uaßerdem dazu verwendet werden, um Spalten zu aktivieren und zu deaktiveren.


Dateisuche Fenster

Das Fenster zur Dateisuche erlaubt es Ihnen nach alten, besonders großen oder temporären Dateien zu suchen. Es gibt folgende Seiten im Fenster:

Größte Dateien Diese Seite bietet die Möglichkeit Ihre Festplatten nach besonders großen Dateien zu durchsuchen. Sie müssen eine minimale Größe in Kilobytes oder Megabytes angeben. Alle Dateien, die größer als dieser Wert sind, werden dann in der Liste aufgeführt.

Älteste Dateien Diese Seite erlaubt es nach Dateien zu suchen, auf die seit einem bestimmten Datum nicht mehr zugegriffen wurde oder die seit einem bestimmten Datum nicht mehr geändert worden sind. Die Suche kann auf komplette Ordner eingeschränkt werden, es werden dann diejenigen Ordner aufgeführt, in denen alle Dateien seit dem angegebenen Datum nicht mehr geändert bzw. geladen worden sind.

Temporäre Dateien Diese Seite zeigt temporäre Dateien an, die vermutlich nicht mehr benötigt werden. Verwenden Sie die Schaltfläche "Konfigurieren", um die Einstellungen der temporären Dateisuche anzupassen.

Internet Dateien Diese Seite zeigt temporäre Internet Dateien an. Dazu gehören zum Beispiel die Seiten und Grafiken im Cache der Browser Netscape Navigator und Internet Explorer. Diese Dateien verursachen auf FAT Laufwerken viel verschwendeten Speicherplatz, da sie meist sehr klein sind.

Optionen Auf dieser Seite können die Laufwerke ausgewählt werden, auf die sich die Suche erstrecken soll und es können die Such-Arten ausgewählt werden, die durchgeführt werden sollen. Es können zusätzliche Pfade oder Laufwerke mit den Schaltflächen unterhalb der Liste der Laufwerke hinzugefügt werden.

Auf der rechten Seite des Fensters stehen folgende Schaltflächen zur Verfügung:

Start Diese Schaltfläche startet die Suche. Sie können nach dem Start entweder das Fenster ausblenden und die Ergebnisse später betrachten, oder Sie können sich bereits Teilergebnisse auf den einzelnen Seiten anschauen. Es ertönt ein kurzes akustisches Signal, wenn TreeSize Professional die Suche beendet hat.

Stop Diese Schaltfläche hält die Suche an.

Fenster ausblenden Mit dieser Schaltfläche kann das Fenster zur Dateisuche ausgeblendet werden, die Suche wird dadurch nicht unterbrochen. Sie können sich die Suchergebnisse dann später anschauen. Solange die Suche noch läuft, wird unterhalb dieser Schaltfläche eine Animation angezeigt.

Ergebnisse Speichern Diese Schaltfläche erlaubt es, die Ergebnisse der gerade sichtbaren Suchart abzuspeichern. Die Ergebnisse werden dabei durch Tabulatoren unterteilt in eine Textdatei gesichert.

Markierte Verschieben Diese Schaltfläche verschiebt oder löscht alle durch einen Haken markierten Dateien auf den einzelnen Seiten. Sie können auswählen, ob die markierten Dateien in den Papierkorb verschoben werden sollen, komplett von der Festplatte gelöscht oder an einen beliebigen Ort im Dateisystem verschoben werden sollen. Wenn Sie die markierten Dateien zu einem bestimmten Pfad im Dateisystem verschieben, bleibt die Verzeichnisstruktur erhalten. Sie können die Dateien dann zum Beispiel in einer ZIP-Datei oder auf CD-R(W) archivieren.
TIPP: Sie können einfach eine aufeinander folgende Gruppe von Dateien markieren, indem Sie die Leertaste mehrmals hintereinander drücken. Es können auch mehrere Einträge mittels der Shift- und Strg-Tasten ausgewählt und dann durch den Kontextmenüeintrag 'Markieren' markiert werden.


Temporäre Dateisuche - Konfiguration

Muster
Der zentrale Teil der temporären Dateisuche basiert auf typischen Mustern von Dateinamen. Diese Muster können konfiguriert werden, nachdem die Schaltfläche "Konfigurieren" im oberen Teil der temporären Dateisuche betätigt worden ist. Es können dann einzelne Muster editiert, gelöscht oder hinzugefügt werden. Durch die Checkboxen auf der linken Seite können einzelne Muster auch vorübergehend deaktiviert werden.

Dateien mit gesetztem Attribut für "temporär" einbeziehen
Anwendungen, die temporäre Dateien erstellen, können das System über diesem Umstand durch Setzen eines speziellen Attributs informieren. Ist diese Option aktiviert, fügt TreeSize Professional 3 auch diese Dateien der Ergebnisliste hinzu.

Dateien einbeziehen, die zu keinem gültigen Benutzeraccount gehören
Wird ein Benutzerprofil unter Windows gelöscht, werden nicht automatisch alle Dateien gelöscht, die als Besitzer dieses Benutzerpofil haben und belegen so weiterhin Plattenplatz. Durch Aktivierung dieser Option werden solche Dateien der Ergebnisliste hinzugefügt. Da für jede Datei zunächst der zugehörige Besitzer bestimmt werden muss, verlangsamt die Aktivierung dieser Option den Scan-Prozess signifikant.

Verweise ohne gültiges Ziel einbeziehen
Durch Aktivierung dieser Option überprüft TreeSize Professional 3 .LNK und .PIF Dateien daraufhin, ob der zugehörige Zielpfad noch existiert. Ist dies nicht der Fall, so werden die entsprechenden Dateien der Ergebnisliste hinzugefügt.


Registrierung / Bestellung

Vielen Dank für Ihr Interesse an TreeSize Professional. Es gibt folgende Möglichkeiten der Bestellung:

1 Eine Sichere Online Bestellung ist über unsere Internet Seite möglich.

2. Firmen innerhalb der EU können auch gegen Rechnung bestellen. Eine aktuelle Preisliste für Mehrbenutzer-Lizenzen finden Sie auf unserer Internet Seite. Ihre Bestellung senden oder faxen Sie bitte an:

JAM Software
Joachim Marder
Bruchhausenstr. 1
D-54290 Trier

Fax: 0700-70707059
E-Mail: sales@jam-software.com
WWW: www.jam-software.de

Nach Ihrer Registrierung erhalten Sie die Informationen, wie Sie die Vollversion herunterladen können. Registrierte Benutzer erhalten bei Problemen Hilfe per E-Mail und können zukünftigen Versionen innerhalb einer Hauptversionsnummer wie V3.x ohne zusätzliche Kosten herunterladen.


Copyright & Kontakt

Copyright Ó1996-2005 by

JAM Software
Joachim Marder
Bruchhausenstr. 1
D-54290 Trier

FAX: 0700-70707059

E-Mail: treesize@jam-software.com

WWW: http://www.jam-software.de


.topic 1

TreeSize Professional ist ein leistungsfähiger und vielseitiger Manager für den Platz Ihrer Festplatte unter Windows 98/ME/NT/2000/XP. Finden Sie heraus, welche Verzeichnisse den meisten Platz belegen und gewinnen Sie viele Megabytes auf Ihrer Festplatte zurück. TreeSize Professional zeigt ihnen für jedes Verzeichnis dessen Größe, den tatsächlich belegten Platz, den durch das Dateisystem verschwendeten Platz, Anzahl der Objekte, 3D Balken und Tortendiagramme, das Datum des letzten Zugriffs, Besitzer, NTFS Kompressionsrate und noch vieles mehr an. Außerdem unterstützt es bei der Suche nach überflüssigen, temporären, sehr großen oder sehr alten Dateien. Die Anwendung hat eine intuitive, an den Explorer angelehnte Benutzeroberfläche und arbeitet im Hintergrund. Sie können detaillierte Berichte und Diagramme ausdrucken, oder die gesammelten Daten in eine HTML, XML oder Textdatei speichern, oder in Excel exportieren.

Für jede Schaltfläche und jeden Menüpunkt zeigt TreeSize Professional eine kurze Beschreibung in der Statuszeile des Fensters an. Falls noch Fragen offen bleiben sollen, können Sie JAM Software kontaktieren.

    Tipps & Anmerkungen

    Einstellungen

    Verschwendeter Platz

    Diagramme

    Drucken

    Dateisuche

    Registrierung

.topic 35
Änderungen in Version 3.3:
Für die Größeneinheiten wurde ein gemischter Modus eingeführt, in dem die Einheit (KB/MB/GB) in Abhängigkeit von dem angezeigten Wert automatisch ausgewählt wird.
TreeSize Pro wertet nun die Windows Meldungen über Änderungen im Dateisystem aus, um die betroffenen Ordner automatisch im Hintergrund zu aktualisieren. Bereits TreeSize Pro V3.0 hat die Größe eines Verzeichnisses (nicht rekursiv) aktualisiert, wenn dieses auf dem Reiter "Details" aufgelistet worden ist. Alle automatischen Updates können nun über eine neue Schaltfläche in der Symbolleiste ein- und ausgeschaltet werden.
Eine neue Spalte wurde hinzugefügt, die die Versionsnummer anzeigen kann, die in den meisten EXE, DLL, OCX etc. Dateien enthalten ist. Es wurde außerdem eine Spalte hinzugefügt, die den Titel eines Scans (z.B. Name des Volumes und  Laufwerksbuchstaben) anzeigt. Dies kann nützlich bei der Archivierung der gesammelten Daten sein kann.
Das Kontextmenü der Einträge auf dem Reiter "Details" enthält jetzt ein Untermenü mit allen Informationen über den angewählten Eintrag, darunter auch die von nicht eingeblendeten Spalten. Dieses Menü kann auch zum Ein- und Ausblenden von Spalten verwendet werden.
Das Hauptmenü hat jetzt einen neuen Punkt "Zweig", der alle Aktionen zusammenfasst, die auf einen kompletten Scan bzw. Zweig angewendet werden können. Der Menüpunkt "Alles aktualisieren", der sämtliche in  TreeSize Pro sichtbare Scans aktualisiert, wurde vom Menü "Datei" in das Menü "Extras" verschoben.
Die Reiter "Benutzer" und "Dateitypen" verfügen jetzt über ein kleines horizontales Balkendiagramm dass die Verteilung der Größen auf die einzelnen Benutzer / Dateitypen visualisiert.
Der neue Kommandozeilen-Parameter /EXCLUDE erlaubt die Angabe von Mustern, die beim Scannen ignoriert werden sollen.
Der neue Kommandozeilen-Parameter /OPEN ermöglicht das Öffnen eines  gespeicherten XML Reports beim Programmstart. Sie kann mit /COMPARE kombiniert werden.
TreeSize Pro wird jetzt mit einer XSLT-Datei geliefert, die den Inhalt einer gespeicherten XML-Datei für die Darstellung in einem Web Browser (z.B.  Firefox >V1.0 und Internet Explorer >V5.5) visualisiert. Bei umfangreichen XML-Dateien benötigen die Browser aber möglicherweise eine längere Zeit  zum Verarbeiten der Daten.
Wird ein Laufwerk oder ein Pfad aus der Dropdown Box in der oberen linken Ecke des Hauptfensters ausgewählt, so startet der Scan jetzt sofort. Das Drücken der Schaltfläche zum Starten daneben ist nun nicht mehr erforderlich.
Der Forschritt beim Drucken eines Reports und beim Vergleichen mit einer XML Datei werden jetzt in einem kleinen Fortschrittsfenster angezeigt.
Die zusätzliche Spalte "TreeSize" für den Windows Explorer folgt jetzt keinen symbolischen Links und Mountpoints mehr, um mit dem Windows Explorer  konsistente Ergebnisse zu liefern und lange oder unerwünschte Rekursionen im Dateisystem zu vermeiden.
Bugfix: Der Kommandozeilen-Parameter /EXTENSIONSLIST hat nicht korrekt funktioniert.
Einige kleinere Fehler wurden behoben und weitere kleine Verbesserungen sind eingeflossen.

Änderungen in V3.22:
Der freie Plattenplatz wird jetzt auch für Netzwerklaufwerke im Tortendiagramm angezeigt. Die Anzeige des freien Platzen kann über das Kontextmenü des Tortdiagramms ein bzw. ausgeschaltet werden.
Das Format der Hilfedatei wurde von Winhelp (.HLP) auf HTMLHelp (.CHM)  umgestellt.
Alle Exporte sind nun etwas schneller
Der Excel Export ist jetzt robuster gegenüber bereits in den Excel-Dateien enthaltenen Daten. Sind die Kopfzeilen in den Optionen deaktiviert, so werden jetzt oberhalb der Daten keine Leerzeilen mehr gelassen.
Einige kleinere Korrekturen

Änderungen in V3.21:
Es wurden einige unkritische Fehlermeldungen beseitigt, die gelegentlich beim Beenden des Programms auftraten, wenn noch Scans aktiv waren.
Es gibt im Menü "Ansicht" jetzt wieder den Menüpunkt zum Ein- und Ausblenden  der Symbolleisten.
Bugfix: Die Sortierreihenfolge war teilweise falsch, wenn die Ansicht auf  einen Benutzer oder einen Dateityp eingeschränkt war.
Bugfix: Die Beschriftung [Dateien] hat bei den gedruckten Berichten gefehlt.
Die neue zusätzlich TreeSize Spalte für den Windows Explorer sortiert nun auch korrekt. Um dies zu erreichen, musste von KB nach MB gewechselt werden und das Tausendertrennzeichen weggelassen werden. Dateien größer als 4GB werden nun ebenfalls korrekt behandelt. Außerdm kann die Spalte jetzt  einfacher über das Kontextmenü der Spaltenköpfe des Windows Explorer aktiviert werden.
Weitere kleinere Verbesserungen.

Änderungen in V3.2:
TreeSize Pro wird jetzt mit einer Shell Extension ausgeliefert, die eine  zusätzliche Spalte zum Windows Explorer hinzufügt. Diese Spalte zeigt die Größe nicht nur für Dateien sondern auch für Ordner an und ist dazu gedacht sich einen schnellen Überblick zu verschaffen. Die Spalte kann im Windows Explorer unter "Ansicht / Details auswählen" aktiviert werden.
Vergleichbar mit der Funktion "Linke Seite auf diesen Benutzer einschränken" aus der Benutzer-Ansicht ist es jetzt möglich, die linke Seite nachträglich  auf eine bestimmte Dateiendung einzuschränken.
Die Dateisuche verfügt jetzt über einen zusätzlichen Reiter "Optionen für Anzeige", mit dem sich die Anzahl der Dezimalstellen und die Einheit (KB, MB, GB, Gemischt) für die Anzeige der Dateigrößen in den Ergebnislisten einstellen lässt.
Passt eine Datei zu mehr als einer Suchart der Dateisuche, so erscheint sie jetzt in allen Ergebnislisten, und nicht nur in der ersten.
Die Dateisuche startet jetzt einen eigenen Thread für jedes ausgewählte Laufwerk bzw. jeden ausgewählten Pfad, was die Geschwindigkeit erhöhen sollte.
Der ausgewählte Drucker und die Orientierung des Papiers werden jetzt gespeichert und beim nächsten Start wieder hergestellt.
Die Geschwindigkeit des Exports wurde erhöht. Außerdem erscheint jetzt beim Export und beim Speichern ein Fortschrittsbalken.
Die Exportroutinen "Als Textdatei speichern" und "Kopieren" nutzen den Speicher jetzt effizienter aus, so dass keine Fehlermeldungen über  nicht ausreichenden Hauptspeicher mehr auftreten sollten.
Die nach Excel exportierten Arbeitsblätter sind jetzt mit dem aktuellen Datum anstatt mit "Tabelle 1" etc. beschriftet.
In den Optionen kann jetzt für jedes Exportmedium einzeln festgelegt werden, ob eine Kopfzeile hinzugefügt werden soll.
Exportierte Dateien enthalten jetzt Informationen über aktive Filter sowie eine Information darüber, ob die Sicht auf einen Benutzer oder eine Dateiendung eingeschränkt war.
Die Funktion "Kopiere Dateiliste" exportiert jetzt auch das Erstellungs- datum der Dateien.
Neue Kommandozeilen Option /USERSLIST die das exportieren der Benutzerliste in eine Datei erlaubt.
Weitere kleinere Verbesserungen

Änderungen in V3.13
Bugfix: In vorangegangenen Versionen wurden Dateien, deren Größe nur um wenige Bytes differierte, unter Umständen nicht korrekt in der Detail-Liste sortiert.
Bugfix: Das Selektieren einer Großen Anzahl von Einträgen in der Detail-Liste nahm eine sehr lange Zeit in Anspruch. Die wurde jetzt optimiert.
Die Größen im Dateisystembaum werden jetzt aktualisiert, wenn eine Datei in der Detail-Liste gelöscht wird.
Bugfix: Die letzte Spalte hat in exportierten Dateien hat gefehlt.
Bugfix: Der Menüpunkt "Liste Speichern" in der Liste der Dateiendungen hat nicht korrekt funktioniert.
Für exportierte Textdateien wird jetzt das in der Systemsteuerung festgelegte Listentrennzeichen verwendet, anstatt standardmäßig der Tabulator.
Dies soll die Kompatibilität mit anderen Anwendungen wie Tabellenkalkulationen und Datenbanken erhöhen. Falls Sie exportierte Dateien automatisiert weiterverarbeiten, müssen Sie unter Umständen Ihre Skripte der die Einstellung in der Systemsteuerung modifizieren.
Bugfix: Wenn die Ansicht auf einen Benutzer eingeschränkt war, wurden alle Dateien in der Detail-Liste mit der Größe 0 gelistet, unabhängig von ihrer tatsächlichen Größe.
Wenn der Baum auf einen bestimmten Benutzer eingeschränkt wird, so wird dieser in der Liste der Benutzer nun fett angezeigt.
Bugfix: Wurde die Baumansicht auf einen Benutzer eingeschränkt, so wurde als Größe in den [Dateien] Einträgen immer 0 angezeigt.
Die Geschwindigkeit der Dateisuche wurde erhöht.

Änderungen in V3.1:
Verbesserungen der Benutzeroberfläche, Verbessertes Aussehen unter dem XP-Style, Neue Icons.
Diagramme können jetzt auch im PNG-Format gespeichert werden.
Einzelne Spalten in der Detail-Liste können jetzt auch mittels des Kontextmenüs des Spaltenkopfes aktiviert und deaktiviert werden, ähnlich wie beim Windows Explorer.
Neue Spalte, die die durchschnittliche Dateigröße anzeigt.
Neue Spalte, die die Zugriffsberechtigungen von Benutzern und Gruppen für Ordner und Dateien anzeigt.
Balkendiagramme, die als Grafik abgespeichert werden, enthalten jetzt alle Balken, und nicht wie vorher nur die im Fenster sichtbaren.
Excel Dateien werden jetzt ohne die Hilfe von MS Excel erstellt, so dass keine installierte Version von MS Excel mehr vorausgesetzt wird. Zusätzlich läuft der Excel Export jetzt auch schneller und stabiler als vorher.
In den Optionen kann jetzt eine Standard-Datei für den Excel-Export angegeben werden. Diese wird immer beim manuellen starten des Excel Exports verwendet. Um die Datei zu ändern, wählen Sie bitte in den Optionen auf dem Reiter "Spalten" in der Dropdown Box "Excel" aus.
Es kann jetzt für jedes Export-Medium einzeln eingestellt werden, ob nur die aufgeklappten Teile des Verzeichniszweiges exportiert werden sollen, oder der gesamte Verzeichnisbaum. Diese Einstellung kann in den Optionen auf der Seite "Spalten" angepasst werden.
Neue Kommandozeilen Option /COMPARE, die ein Verzeichnis nach abgeschlossenem Scan mit einem gespeicherten XML-Report vergleicht. Diese Option kann mit anderen Kommandozeilen Optionen kombiniert werden, um beispielsweise die Ergebnisse eines Vergleichs in eine Excel Datei zu speichern.
An der Kommandozeile werden jetzt Platzhalter unterstützt, z.B. \\Server\Users\A*
Im Kontextmenü des Kreisdiagramms gibt es jetzt eine Option, mit der sich die Anzeige des freien Plattenplatzes für die Wurzel ein- und ausschalten lässt.
Wird der Verzeichnisbaum auf einen bestimmten Benutzer eingeschränkt, so zeigt die Detail-Liste jetzt nur noch Dateien dieses Benutzers an.
Für bekannte Dateiformate wird jetzt ein Vorschaubild in der rechten unteren Ecke des Fensters der Dateisuche angezeigt.
Die Minimalgröße für die Suche nach den größten Dateien wurde in der Vorversion nicht gespeichert. Dies ist jetzt korrigiert.
Einige weitere kleine Fehlerkorrekturen und Verbesserungen wurden eingearbeitet.

Änderungen in V3.03:
Wenn ein Verzeichnis ohne Unterverzeichnisse angewählt wird, werden nun die Dateien in diesem Verzeichnis im Diagramm angezeigt.
Bugfix: In der Suche nach ältesten Dateien wurde bei aktivierter Option "Nur komplette Verzeichnisse" nicht die korrekten Icons für die Verzeichnisse angezeigt.
Bugfix: In der Suche nach ältesten Dateien wurden bei aktivierter Option "Nur komplette Verzeichnisse" die Verzeichnisgrößen nicht korrekt berechnet.
Bugfix: Das falsche Kontextmenü wurde für die [Dateien] Einträge im Baum angezeigt.
Bugfix: Das Verändern der Einheit (KB, MB, GB) während des Scans führte nicht immer zu einer Aktualisierung des kompletten Dateisystem-Baumes.
Einige kleinere Bugfixes sind ebenfalls in diese Version eingeflossen.

Änderungen in V3.02:
Die Exclude-Muster der Dateisuche wurden bislang nicht gespeichert. Dies wurde jetzt geändert.
Unter Bestimmten Bedingungen wurden nicht alle Dateien, die in der Dateisuche angewählt waren, auch tatsächlich verschoben.
Beim Speichern der Suchergebnisse der Dateisuche kann jetzt auch das CSV-Format ausgewählt werden, welches kompatibler mit Excel ist.

Änderungen in V3.01:
Der Export in eine Textdatei produzierte eine leere Datei, wenn die Option "Kopfzeile" im Export-Menü nicht aktiviert war.
Es wurde ein Fehler in der Dateisuche beseitigt, der aufgetreten ist, wenn zum Sortieren auf den Spaltenkopf der Spalte mit dem Dateityp geklickt worden ist.
Die Bilder in der Hilfe-Datei und dem PDF-Handbuch haben gefehlt.
In sehr seltenen Fällen kam es beim Programmstart zu einer Fehlermeldung, wenn die MAPI32.DLL nicht gefunden worden ist.

Änderungen in V3.0:
TreeSize Pro kann die Ergebnisse jetzt in einer zusätzlichen Liste gruppiert  nach Benutzern anzeigen. Die Daten in der Verzeichnisstruktur lassen sich  außerdem auf einen Benutzer einschränken.
TreeSize Pro kann jetzt seine Daten in eine XML-Datei speichern und später wieder laden.
Eine gespeicherte XML-Datei kann zum Vergleich mit dem derzeitigen Stand des Dateisystems genutzt werden. Es wird dann die Differenz der beiden Scans angezeigt, was das Erkennen von stark gewachsenen Ordnern erleichtert.
Die Spalten können jetzt in Abhängigkeit vom Ausgabe-Medium (TreeSize Pro Fenster, ASCII-Datei, Excel, gedruckter Report) ausgewählt und sortiert werden.
Es sind neue Spalten hinzugekommen: Attribute, Verzeichnisebene, Dateityp
Eine neue Symbolleiste gibt jetzt einen schnellen Überblick über das gescannte Verzeichnis.
Ein Report kann jetzt per E-Mail (via MAPI) versandt werden.
Es ist jetzt möglich, in den Optionen den Scan auf Dateien einzuschränken, die das Archiv-Attribut gesetzt haben. Auf diese Weise kann man z.B. die Größe von Backups ermitteln.
TreeSize Pro scannt jetzt Ordner die auf sein Fenster gezogen werden.
Im Kontextmenü gibt es nun einen Eintrag "Aus TreeSize entfernen", der den betreffenden Ordner aus dem Verzeichnisbaum von TreeSize entfernt (ohne ihn auf dem Laufwerk tatsächlich zu löschen) und die Verzeichnisgrößen neu berechnet.
In den Optionen können Sie einen Scan jetzt auf Dateien einschränken, die in den letzten XX Tagen erstellt worden sind. Auf diese Weise können Ordner identifiziert werden, die in jüngster Zeit stark angewachsen sind.
Der Inhalt aller Listen kann jetzt über deren Kontextmenü in die Zwischenablage exportiert werden.
Das Kontextmenü des Verzeichnisbaumes bietet jetzt die Möglichkeit, auch Unterzweige in die Zwischenablage zu kopieren.
Wenn ein ausgewählter Ordner in der Detailansicht angezeigt wird, berechnet TreeSize Pro die Verzeichnisgröße für dies Verzeichnis jetzt neu und aktualisiert seine Daten.
Es gibt jetzt ein Kontextmenü zum Ein- und Ausblenden der einzelnen Symbolleisten
Die ausgewählte Größeneinheit wird jetzt auch für die Anzeige der Werte in der Statusleiste verwendet.
Mit dem neuen Kommandozeilen-Parameter /TITLE kann der Standard-Titel, der beim Exportieren oder Drucken verwendet wird, verändert werden. Auf diese Weise können Sie beispielsweise in einer automatisierten Umgebung zusätzliche Informationen übermitteln.
Neuer Kommandozeilen-Parameter /EMAIL zum Versenden eines Reports per Mail
Neuer Kommandozeilen-Parameter /FILTER zum Einschränken des Scans auf  bestimmte Dateitypen.
Neuer Kommandozeilen-Parameter /RESTRICTED der TreeSize Pro in eine Art "nur lesen"-Modus versetzt, der keine Manipulationen am Dateisystem erlaubt.

Dateisuche:
Es ist jetzt möglich, die markierten Dateien nicht nur zu löschen, sondern auch in eine ZIP-Datei zu verschieben.
Die Dateisuche verfügt jetzt über eine Exclude-Liste. Eine Datei oder ein Ordner, das eines der angegebenen Strings enthält, wird in den Ergebnissen nicht berücksichtigt.
Dateien die mit dem Attribut FILE_ATTRIBUTE_TEMPORARY erstellt worden sind, Können jetzt in die Suche nach temporären Dateien einbezogen werden.
Ebenfalls kann jetzt nach Dateien gesucht werden, die keinem existierenden Benutzer zugeordnet sind.
Es kann jetzt auch nach Verknüpfungen gesucht werden, die kein gültiges Ziel mehr haben.
Jedes Suchmuster bei der Suche nach temporären Dateien hat jetzt eine Checkbox, mit der es individuell aktiviert und deaktiviert werden kann.
Die Größe von Ordnern wird jetzt in der Dateisuche angezeigt.
Der Kommandozeilen-Parameter /SAVE funktioniert jetzt auch mit der Dateisuche und speichert die Suchergebnisse in einer Textdatei

Neue Funktionen in V2.4:
TreeSize Professional kann nun Verzeichnisse unter Windows NT4/2000 untersuchen, auf die der aktuelle Nutzer eigentlich keinen Zugriff hat. Man muss sich dazu entweder als Administrator angemeldet haben, oder als Nutzer, der das Recht hat, Backups durchzuführen. In den vorangegangenen Versionen von TreeSize Professional wurde hier lediglich die Fehlermeldung "Zugriff verweigert" angezeigt.
Es gibt eine neue Option im Einstellungen-Dialog, mit der festgelegt werden kann, ob TreeSize Professional beim Scannen Mountpoints und symbolischen Links folgen soll oder nicht. (Dies sind neue Funktionen von Windows 2000)
TreeSize Pro berücksichtigt nun die Kompression auf NTFS Laufwerken bei der Berechnung des Belegten Platzes.
Komprimierte Dateien und Verzeichnisses in blauer Farbe angezeigt werden. Wenn nur ein Teil eines Verzeichnisses komprimiert ist, wird dieses in dunkelblau angezeigt.
In einer zusätzlichen Spalte in der Detailansicht wird nun die Kompressionsrate von Dateien und Verzeichnissen auf angezeigt.
Die Einstellung, ob die Werte in KB oder MB angezeigt werden, wurde zwecks schnelleren Zugriffs vom Einstellungen-Dialog in die Symbolleiste verlagert.
Die Diagramme können jetzt auch als JPG-Datei gespeichert werden.
Es besteht jetzt die Möglichkeit des HTML-Exports. Dies kann entweder in Hauptmenü unter Datei/Export/Als HTML Speichern oder mit der Kommandozeilen-Option /HTML geschehen. HTML Reporte haben den Vorteil, dass sie einfacher zu lesen sind als Text Reporte und es wird keine spezielle Anwendung wie MS Excel benötigt.
Das Software Applet der Systemsteuerung kann jetzt aus der Symbolleiste von TreeSize aufgerufen werden.
Neben der Funktion, Verzeichnisse in fetter Schriftart anzuzeigen, die größer als ein einstellbarer Prozentsatz des untersuchten Verzeichnisses sind, kann jetzt alternativ auch ein fixer Schwellwert in MB angegeben werden. Diese Einstellung kann jetzt auch für den Druck von Reporten verwendet werden und verschafft so einen schnelleren Überblick über die größten Verzeichnisse.
Es ist jetzt möglich, alle sichtbaren Freigaben eines Servers auf einmal zu untersuchen, indem man den Namen des Servers in der Form \\HOSTNAME in die Laufwerksbox in der Symbolleiste eingibt.
Die Laufwerksbox verfügt bei der manuellen Eingabe jetzt über eine AutoComplete Funktion ähnlich den neuen Versionen des Windows Explorer.
Neue Option im Einstellungen-Dialog: Die Diagramme und die Detailansicht können jetzt während dem Scannen automatisch aktualisiert werden.
Eine zusätzliche Spalte der Detailansicht zeigt jetzt unter Windows NT4/2000 den Namen des Dateibesitzers an.
Dateien, die noch geöffnet sind, werden jetzt automatisch von den Suchergebnissen der Dateisuche ausgeschlossen.
Große Balkendiagramme können jetzt mit dem Mausrad gescrollt werden. Tortendiagramme können mit dem Mausrad rotiert werden.
Die Kommandozeilenoption /CHART wurde durch /BARCHART und /PIECHART ersetzt.
Tsizepro.exe wurde mit UPX komprimiert.

.topic 36
Besonders auf großen Netzwerklaufwerken kann ein Scan sehr lange dauern. Sie können in diesem Fall auch Scans über Nacht mit Hilfe der Kommandozeilen-Parameter von TreeSize Professional 3 durchführen und die Ergebnisse in einer XML-Datei speichern. Diese Daten können später wieder in TreeSize Professional 3 geladen und analysiert werden.
Alle Verzeichnisse, die im Verzeichnisbaum in der linken Hälfte des Fensters sichtbar sind, werden auch im gedruckten Bericht oder der exportierten Datei zu sehen sein. Sie können in den Optionen aber auch einstellen, dass stets der gesamte Verzeichnisbaum exportiert bzw. gedruckt wird.
Das Datum des letzten Zugriffs ist das Datum, an welchem eine Datei zuletzt benutzt oder geladen wurde. Für Programme oder DLLs ist dies zum Beispiel das Datum, an dem Sie zuletzt ausgeführt wurden und für Grafiken, wann sie zum letzten Mal angezeigt worden sind. Wenn also auf eine Datei seit längerer Zeit nicht zugegriffen wurde, wird diese auf Ihrem System wahrscheinlich nicht mehr benötigt. Das Datum des letzten Zugriffs kann beispielsweise dazu verwendet werden, überflüssige DLLs im Windows Systemverzeichnis zu identifizieren.
Mit der Festlegung einer benutzerdefinierten Blockgröße können Sie testen, wie die Werte für den belegten und verschwendeten Platz Ihrer Festplatte mit einer anderen Blockgröße aussehen würden. Dazu ist allerdings ein erneutes Einlesen Ihrer Verzeichnisstruktur notwendig.
Verwenden Sie die CD-ROM Blockgröße um zu sehen, wie viel Platz ein Verzeichnis auf einer CD-ROM belegen würde. Bitte beachten Sie dabei, dass auf einer CD-R(W) noch zusätzlich einige MB für die Verzeichnisinformationen benötigt werden.
Im Papierkorb werden Sie nicht die selbe Darstellung wie im Explorer sehen. Dies ist notwendig, um den tatsächlich belegten Platz und das Datum des letzten Zugriffs zu bestimmen.
Sie können alle freigegebenen Laufwerke einer Domäne scannen, in dem Sie den Namen der Domäne einfach in die Laufwerksbox von TreeSize Professional 3 eingeben.
TreeSize Professional 3 wird mit einer XSLT-Datei ausgeliefert, die die Daten ein solchen XML Datei für die Darstellung in XSLT-fähigen Browser konvertiert  (z.B. Firefox >V1.0 oder Internet Explorer >V5.5).
Verwenden Sie die Dateisuche um überflüssige Dateien auf ihren Laufwerken zu suchen.
Für die Überwachung und Verwaltung sehr großer Server empfehlen wir Ihnen unser Produkt SpaceObServer, dass Laufwerke mittels eines Hintergrunddienstes einliest und seine Daten in einer SQL-Datenbank ablegt. Es benötigt wesentlich weniger Hauptspeicher und bietet wesentlich flexiblere Reporting Funktionen wie z.B. Historien. Mehr über dieses Produkt erfahren Sie unter: http://www.jam-software.de/spaceobserver/

.topic 545
TreeSize Professional 3 wird jetzt mit einer Shell-Erweiterung ausgeliefert, die dem Windows Explorer eine zusätzliche Spalte hinzufügt. Diese Spalte zeigt die Größe nicht nur für Dateien sondern auch für Ordner an und ist dazu gedacht sich einen schnellen Überblick zu verschaffen. Die Spalte kann im Windows Explorer unter Ansicht / Details auswählen aktiviert werden, oder über das Kontextmenü der Kopzeile der Detailansicht des Windows Explorer. Die Spalte steht nicht für Windows 95/98 zur Verfügung.

.topic 9
Der verschwendete Platz ist der ungenutzte Platz in Festplattenblöcken, die nicht komplett gefüllt sind. Dies ist jeweils bei dem letzten (oder einzigen) Block einer Datei der Fall. Behalten Sie immer folgende Formel im Hinterkopf:  Größe  + verschwendeter Platz = belegter Platz. Windows 95 mit seinem Dateisystem FAT kann abhängig von der Größe der  Partition sehr große Blockgrößen haben:

           FAT	FAT32
Partitionsgröße      	Clustergröße	Partitionsgröße	Clustergröße
128 - 256 MB  	4 KB	1 - 8 GB	4 KB
257 - 512 MB   	8 KB	8 - 16 GB	8 KB
513 - 1024 MB  	16 KB	16 - 32 GB	16 KB
1025 - 2048 MB 	32 KB	>32 GB	32 KB

Wenn Sie beispielsweise eine Partition der Größe 1,2GB haben, werden darauf Blöcke der Größe 32KB verwendet. Wenn Sie dort nun 10 Dateien mit einer Größe von je 1KB speichern wollen, würden Sie dazu 10*32KB=320KB Ihres wertvollen Festplattenplatzes benötigen, und 320KB-10KB=310KB wären verschwendeter Platz.

Um den verschwendeten Platz zu reduzieren, haben Sie folgende (nicht immer befriedigenden) Möglichkeiten:

Erstellen Sie kleinere Partitionen. Sie sollten FAT32 Partitionen größer als 16GB vermeiden. Allerdings bedeuten kleinere Partitionen auch eine größere Anzahl von Partitionen und somit von Laufwerksbuchstaben.

Windows NT/2000/XP bieten die Möglichkeit, auf einer Partition das NTFS Dateisystem zu verwenden. Es arbeitet normalerweise mit Blockgrößen von 512-4096 Bytes und speichert Daten deshalb am effizientesten von allen Windows Dateisystemen. NTFS Partitionen können allerdings nicht von Windows 9x oder DOS aus angesprochen werden. Zusätzlich bietet NTFS noch die Möglichkeit, einzelne Verzeichniszweige zu komprimieren.

.topic 11
TreeSize Professional hat umfangreiche und flexible Druck-Funktionen:

Sie können einen detaillierten Bericht drucken, indem Sie im Datei-Menü 'Drucke Bericht' auswählen oder in der Symbolleiste die Schaltfläche mit dem Druckersymbol drücken. Der Bericht enthält die Verzeichnisstruktur des untersuchten Ordners inklusive Linien zwischen den Verzeichnissen, Größe, belegtem Platz, Anteil am übergeordneten Verzeichnis in Prozent, das Datum des letzten Zugriffs und der letzten Änderung sowie die Anzahl der im Ordner enthaltenen Objekte. Es werden nur die Ordner im Bericht gedruckt, die auch im Verzeichnisbaum im linken Teil des Fensters von TreeSize Professional sichtbar sind. So können Sie auf einfache Weise den Umfang des Berichts anpassen. Wenn Sie einen kompletten Bericht wünschen, wählen Sie zuvor 'Alles Einblenden' aus dem Kontextmenü des obersten Ordners.

Die Spalten, die ein Bericht enthalten soll, kann in den Optionen festgelegt werden.

Wenn die Detailansicht in der rechten Hälfte des Fensters aktiv ist, können Sie den Inhalt eines Ordners drucken, indem Sie 'Drucke Ordnerinhalt' aus dem Datei-Menü wählen. Im Ausdruck sind alle Dateien und Unterordner enthalten, mit Angabe der Größe, dem belegten und verschwendeten Platz, der Anzahl der Objekte sowie dem Datum des letzten Zugriffs und der letzten Änderung.

Wenn in der rechten Hälfte des Fensters ein Diagramm sichtbar ist, können Sie dieses Diagramm ausdrucken, indem Sie 'Drucke Diagramm' aus dem Datei-Menü auswählen. Das Diagramm wird genauso gedruckt, wie es am Bildschirm angezeigt wird.

Verwenden Sie den Menüpunkt 'Seite einrichten' um die Ränder für den Druck einzustellen. Verwenden Sie den Menüpunkt 'Drucker einrichten' um einen Drucker auszuwählen und einzurichten. Mit dem Menüpunkt 'Titel angeben' können Sie einen Titel für den Druck und Export festlegen, standardmäßig besteht dieser aus dem Verzeichnispfad und dem Namen des Laufwerks.

.topic 40
TreeSize Professional kann die Belegung der Festplatte in Form von Balken- und Tortendiagrammen visualisieren. Ein Diagramm zeigt jeweils die Größe der Unterordner des gerade ausgewählten Ordners an. Ein Tortendiagramm zeigt die Größe, den belegten Platz, verschwendeten Platz etc. an, je nachdem welche Ansicht gerade aktiv ist. Ein Balkendiagramm zeigt Größe, belegten und verschwendeten Platz eines Ordners in einem Balken an, hier gilt die Formel: Belegter Platz = Größe + verschwendeter Platz. Wenn nicht alle Balken in das Fenster von TreeSize Professional passen, wird am rechten Rand eine Bildlaufleiste eingeblendet.

Im Tortendiagramm werden kleinere Verzeichnisse zur besseren Übersicht unter "Andere" zusammengefasst. Falls das Wurzelverzeichnis eines Laufwerks angezeigt wird und sich TreeSize im Ansichtsmodus "Belegter Platz" befindet, wird auch der freie Platz des Laufwerks im Tortendiagramm angezeigt. Im Kontextmenü des Tortendiagramms gibt es einen Menüpunkt, um dieses Verhalten ein- oder auszuschalten.

Durch Klicken auf einen Balken oder einen Teil eines Tortendiagramms erhält man ausführlichere Informationen über den dazugehörigen Ordner. Ein Doppelklick macht den ausgewählten Ordner zum aktiven Ordner. In den Einstellungen können Sie die Option 'Symbolleiste für Charts' auswählen, um eine zusätzliche Symbolleiste zur erweiterten Manipulation von Diagrammen einzublenden. Diese ermöglicht zum Beispiel das Speichern des Diagramms als Bitmap- oder JPEG-Datei, Zoomen, das Ändern von Farben und Mustern, das Ein- und Ausblenden der Gitternetzlinien, das Umschalten zwischen 2D und 3D Modus, etc. Sie können Muster und Farben einzelner Diagrammelemente ändern, indem Sie in der Auswahlbox eine Farbe auswählen und anschließend auf ein Diagrammelement klicken.

Ein Diagramm kann gedruckt werden, indem Sie 'Drucke Diagramm' aus dem Datei-Menü auswählen.

.topic 30
TreeSize Professional 3 akzeptiert Kommandozeilen Parameter, die zeitgesteuerte Untersuchungen erlauben.

Tsizepro.exe [/ARCHIVEBITFILESONLY] [/(BAR|PIE)CHART filename] [/COMPARE] [/DATE] [/EMAIL] [/EXCEL filename] [/EXPAND [level|xxMB]] [/FILTER pattern1;pattern2;...] [/HTML filename]  [/NOGUI] [/PRINT] [/SAVE filename] [/SEARCH[:Start|:Internet]] [/TITLE text] [/USERSLIST filename] [/XML]  Directories

/ARCHIVEBITFILESONLY     Diese Option wird nur solche Dateien in die Scans mit einbeziehen, bei denen das Archiv Bit gesetzt ist. Dies kann beispielsweise genutzt werden, um die Größe von Backups zu bestimmen. In diesem Fall können Sie eine Verknüpfung zu TreeSize Professional 3 auf dem Desktop oder im Startmenü erstellen, die automatisch mit der Berechnung der Größe des Backup beginnt:

    tsizepro /ARCHIVEBITFILESONLY \\Server\Backup\This

/BARCHART  Speichert das Balkendiagramm des untersuchten Verzeichnisses als Bitmap oder JPEG Datei, der Typ der Datei wird über die Dateiendung bestimmt. Beispiel:

    tsizepro /CHART C:\Documents\c.jpg C:\

/COMPARE	Vergleicht den untersuchten Pfad oder dens geöffneten XML-Report mit einem gespeicherten XML Report. Das folgende Beispiel untersucht das Laufwerk C: und vergleicht es anschließend mit einem gespeicherten XML Report für dieses Laufwerk:

    tsizepro /COMPARE "C:\temp\TSP XML\c.xml" C:\

/DATE	Diese Option fügt zu jedem Dateinamen, in dem Ergebnisse gespeichert werden und die nach dieser Option auftauchen, Datum und Uhrzeit hinzu. Dies ist besonders nützlich, wenn man regelmäßig zeitgesteuerte Untersuchungen durchführt. Wenn allen Dateinamen Datum und Uhrzeit hinzugefügt werden soll, sollte /DATE der erste Kommandozeilen Parameter sein. Das folgende Beispiel würde den Netzwerkpfad \\host\\share untersuchen und das Ergebnis unter einem Dateinamen der Art C:\scans\name_99-12-20_1550.xls speichern:

    tsizepro /DATE /EXCEL C:\scans\name.xls \\host\share

/EMAIL	Sendet die gesammelten Daten an die angegebene E-Mail Adresse über die MAPI-Schnittstelle von Windows. MAPI muss daher in der Systemsteuerung geeignet konfiguriert sein. Es können mehrere Empfänger angegebene werden, die jeweils durch ein Semikolon oder Komma getrennt werden müssen. Beispiel:

    tsizepro /EMAIL sysadmin@company.com \\SERVER\C$

/EXCEL	Exportiert die gesammelten Ergebnisse in Excel und speichert sie unter dem angegebenen Namen ab. Existiert die Datei bereits, so wird sie geöffnet und die Ergebnisse auf einem neuen Tabellenblatt hinzugefügt. TreeSize Professional 3 wird anschließend beendet. Beispiel:

    tsizepro /EXCEL C:\Dokumente\c.xls C:\

/EXCLUDE	Diese Option erlaubt die Angabe von Mustern für Dateien und Ordner, die beim Untersuchen der Platte ignoriert werden sollen. Mehrere Muster können jeweils durch ein Semikolon getrennt werden. Enthält ein Suchmuster Leerzeichen, so muss der gesamte String in Anführungszeichen gesetzt werden, so wie es im Beispiel unten zu sehen ist. Diese Kommandozeilen-Option entspricht den Ausschlusskriterien in den Optionen. Das folgende Beispiel würde Ordner und Dateien ignorieren, die auf ".001" enden sowie die den Namen ".personal" haben:

    tsizepro /EXCLUDE "*.001;.system" \\server\Users

/EXPAND	Mit diesem Parameter kann festgelegt werden, wie viele Ebenen des Verzeichnisbaumes eingeblendet werden, nachdem die Untersuchung abgeschlossen ist. Wird keine Zahl angeben, so wird der Verzeichnisbaum komplett eingeblendet. Es kann auch eine Angabe in MB gemacht werden was dazu führt, dass alle Verzeichnisse, die größer als der angegebene Wert sind, eingeblendet werden. Bitte beachten Sie, dass sich zwischen der Zahl und der Einheit "MB" kein Leerzeichen befinden darf.  Beispiele:

    tsizepro /EXCEL C:\Results\Allusers.xls /EXPAND 2 H:\user

    tsizepro /EXCEL C:\Results\C.xls /EXPAND 10MB C:\

/EXTENSIONSLIST    Diese Option schreibt die Statistik über die Verteilung der Dateieypen / Dateiendungen des untersuchten Dateisystemzweiges in eine Text- oder CSV-Datei. Das folgende Beispiel untersucht Laufwerk C: und erstellt eine CSV-Datei in C:\Temp mit der Statistik der Dateitypen auf diesem Laufwerk:

    tsizepro /EXTENSIONSLIST C:\temp\C_filetypes.csv C:\

/FILTER	Erlaubt das Setzen eines Filters, so dass nur bestimmte Dateitypen wie *.MP3 oder *.DOC in den Scan mit einbezogen werden. Es können mehrere Filter übergeben werden, die mittels Leerzeichen, Kommata oder Semikola getrennt werden müssen. Das folgende Beispiel sucht nach AVI- und MP3-Dateien im Verzeichnis "Users"direkt auf dem Server:

    tsizepro /EXCEL C:\Results\MediaUsers.xls /FILTER "*.mp3;*.avi" \\Server\Users

/HTML	Speichert die gesammelten Daten in eine HTML-Datei, welche dann mit jedem Internet-Browser angeschaut werden kann. Wird zusätzlich noch der Parameter /PIECHART oder /BARCHART angegeben, wird das entsprechende Diagramm in die resultierende HTML-Datei eingebettet. Das folgende Beispiel erzeugt einen HTML-Report für das Laufwerk C:und speichert diese im Verzeichnis D:\html:

    tsizepro /DATE /HTML d:\html\treesize.html /PIECHART d:\html\treesize.jpg C:\

    Wenn Sie gerne mehrere Verzeichnisse oder Laufwerke untersuchen und exportieren möchten, empfehlen wir, entweder einen gesonderten Aufruf von TreeSize Professional 3 für jedes Laufwerk / Verzeichnis, oder die Kommandozeilen Parameter in der folgenden Art zu verwenden:

    tsizepro /HTML d:\html\drive_c.html /PIECHART d:\html\drive_c.jpg C:\ /HTML d:\html\drive_d.html /PIECHART d:\html\drive_d.jpg D:\

/NOGUI	Dieses Argument bewirkt, dass das Fenster von TreeSize Pro nicht angezeigt wird und nicht in der Taskleiste erscheint. Achtung: Verwenden Sie dieses Argument erst, wenn Sie die restlichen Kommandozeilen Parameter ausreichend getestet haben!

/OPEN	Öffnet einen gespeicherten XML Report beim Start der Anwendung. Beispiel:

    tsizepro /OPEN C:\Reports\Lfw_C.xml

/PIECHART	Speichert das Kreisdiagramm des untersuchten Verzeichnisses als Bitmap oder JPEG Datei. Das folgende Beispiel scannt die Laufwerke  C:\ und D:\ und erstellt für jedes einen Chart:

    tsizepro /PIECHART C:\Temp\c.jpg C:\ /PIECHART C:\Temp\d.jpg D:\

/PRINT	druckt einen Bericht auf dem Standard Drucker aus und beendet die Anwendung anschließend. Beispiel:

    tsizepro /PRINT C:\ D:\

/PRINT1	Druckt nur die erste Seite des Reports für jedes angegebene Verzeichnis / Laufwerk auf dem Standard Drucker aus und beendet TreeSize Professional 3 anschließend. Beispiel:

    tsizepro /PRINT1 \\SERVER\USERS

/RESTRICTED    Startet TreeSize Professional 3 in einer Art "Readonly"-Modus, in denen der Benutzer keinen Zugriff auf das Explorer-Kontextmenü hat, keine Dateien oder Verzeichnisse umbenennen oder löschen darf, und die Schaltflächen zum Hinzufügen von Netzwerklaufwerken und zum Deinstallieren von Software in der Symbolleiste fehlen.

/SAVE 	Speichert die Ergebnisse in einer Textdatei, nachdem die Untersuchung abgeschlossen ist, und beendet das Programm. Beispiel:

    tsizepro /SAVE C:\Scans\c.txt C:\

/SEARCH 	öffnet das Fenster zur Dateisuche von TreeSize Professional 3. Wenn ":Start" zu dieser Kommandozeilen Option hinzugefügt wird, wird die Suche unmittelbar gestartet. Es werden dabei dieselben Einstellungen verwendet, wie bei der letzten Benutzung der Dateisuche. Findet TreeSize Pro dagegen den Zusatz ":Internet" bei dieser Option, so startet es die Suche nach temporären Internet Dateien und löscht diese anschließend. Beispiel:

    tsizepro /SEARCH:Internet

    TreeSize Professional 3 benutzt die selben Einstellungen wie bei der zuletzt durchgeführten Dateisuche. Sie können jedoch die Suchmuster für die Temporäre Dateisuche mittels der  /FILTER Kommandozeilen Option angeben. Tipp: Sie können die Ergebnisse der Dateisuche mit der /SAVE Kommandozeilen-Option in eine Text- oder CSV -Datei speichern.

/TITLE	Kann genutzt werden, um den Titel des gedruckten oder exportierten Reports zu ändern und so noch zusätzliche Informationen anzugeben, wenn TreeSize Professional 3 in einer automatisierten Umgebung genutzt wird. Beispiel:

    tsizepro /TITLE "Dies ist ein Report von Laufwerk C auf Server3" /PRINT \\Server3\C$

/USERSLIST  Diese Option schreibt die Statistik über die Verteilung der Dateigrößen auf die verschiedenen Benutzer des untersuchten Dateisystemzweiges in eine Text- oder CSV-Datei. Das folgende Beispiel untersucht Laufwerk C: und erstellt eine CSV-Datei in C:\Temp mit der Statistik der Benutzer auf diesem Laufwerk:

    tsizepro /USERSLIST C:\temp\C_users.csv C:\

/XML	Speichert die Ergebnisse in einer XML-Datei, die später wieder geladen oder für Vergleichszwecke genutzt werden kann.

    tsizepro /XML C:\Results\Allusers.xml H:\users\

Directories	Am Ende der Kommandozeile können ein oder mehrere Pfade angegeben werden, die TreeSize Professional 3 durchsuchen soll. Die Platzhalter * und ? sind erlaubt. Beispiel:

    tsizepro H:\users\A*

Zeitgesteuerte Scans
Wenn Sie Windows 98/ME oder Windows NT4+ mit installiertem Internet Explorer 5 verwenden, können Sie den Ordner 'Geplante Vorgänge' verwenden, um zeitgesteuerte Untersuchungen mit TreeSize Professional 3 durchzuführen. Fügen Sie dazu einfach einen neuen täglichen Task hinzu und wählen Sie TreeSize Professional 3 als auszuführendes Programm aus. Vor dem Fertig stellen wählen Sie noch aus, weitere Eigenschaften des Task einzustellen und fügen die gewünschten Parameter hinter Tsizepro.exe ein.

Wenn Sie Windows NT 4 oder höher verwenden, können Sie das at-Kommando verwenden, um zeitgesteuerte Untersuchungen durchzuführen. Um beispielsweise eine Untersuchung der Laufwerke C: und E: um 3:00 Uhr nachts durchzuführen, müssen Sie folgendes Kommando an der NT Kommandozeile eingeben:

at 03:00 "C:\Programme\JAM Software\TreeSize Professional 2.4\tsizepro.exe" /EXCEL c:\temp\tsp.xls /EXPAND 2 c:\ e:\

Wenn Sie die Ergebnisse der Dateisuche am nächsten Morgen auf dem Monitor in Ihrem Büro sehen wollen, sollten Sie ein Kommando der folgenden. Art verwenden:

at 06:00 /INTERACTIVE "C:\Program Files\JAM Software\TreeSize Professional 2.3\tsizepro.exe" /SEARCH:Start

Weitere Informationen zum at-Kommando finden Sie in der Windows NT Hilfe. Fehler bei der Ausführung werden im Ereignisprotokoll von Windows NT/2000 festgehalten.

Windows Scripting Host
Wenn Sie den Windows Scripting Host verwenden möchte, sieht das Kommando zum Starten von TreeSize Professional 3 wie folgt aus:

Set Shell = CreateObject("WScript.Shell")
Shell.Run """C:\Program Files\TreeSize Professional\tsizepro.exe"" /XML c:\temp\drive_c.xml c:\"

.topic 27
Das Dateisystem NTFS, das unter den Betriebssystemen Windows NT, 2000 und XP benutzt werden kann, bietet einige besondere Funktionen die auch Auswirkungen auf TreeSize haben. Im Folgenden werden wir einige dieser speziellen Fähigkeiten und ihre Auswirkungen auf TreeSize beschreiben.

Access Control Lists (Zugriffskontrolllisten)
Unter Windows NT und seinen Nachfolgern kann ein Benutzer die Zugriffsmöglichkeiten anderer Nutzer auf seine Dateien und Ordner einschränken, indem er Benutzern oder Benutzergruppen bestimmte Rechte wie das Lesen, Schreiben, Löschen oder Ausführen von Dateien gewährt oder verweigert. Auf diesem Weg kann ein Benutzer sogar dem Administrator den Zugriff auf seine Dateien und Ordner verwehren. Wenn ein Administrator im Windows Explorer versucht, auf eine solche Datei oder einen solchen Ordner zuzugreifen, wird eine Fehlermeldung "Zugriff verweigert" angezeigt. TreeSize Professional kann seit V2.4 trotzdem solche Verzeichnisse untersuchen, wenn Sie als Administrator eingeloggt sind, oder als normaler Benutzer, der das Recht hat, Backups durchzuführen. (Diese Einstellung kann bei Windows 2000 unter Systemsteuerung / Verwaltung / Lokale Sicherheitsrichtlinie und bei Windows NT in der Benutzerverwaltung verändert werden.)

Dateibasierte Kompression
NTFS unterstützt die transparente Kompression einzelner Dateien. Derart komprimierte Dateien können gelesen oder geschrieben werden, ohne vorher mit einem externen Programm (de)komprimiert werden zu müssen. Die Dekompression geschieht vielmehr automatisch beim Lesen einer Datei, genauso wie die Kompression beim Schreiben.

Der Platz, den eine komprimierte Datei auf der Festplatte belegt, ist normalerweise geringer als seine eigentliche Größe. Deshalb kann bei komprimierten Verzeichnissen der von TreeSize ermittelte belegte Platz wesentlich kleiner sein als die angezeigte Größe des Verzeichnisses. Der Kompressionsfaktor wird in einer eigenen Spalte der Detailansicht angezeigt. Außerdem können komprimierte Dateien und Ordner in einer anderen Farbe angezeigt werden (diese Funktion kann in den Einstellungen aktiviert werden).

Seit Windows 2000 beherrscht NTFS ein weiteres Konzept, das der dateibasierten Kompression ähnelt: Sparse Files. So genannt werden sehr große Dateien, die aber nur in Teilbereichen Daten enthalten. Da das Betriebssystem für die ungenutzten Teilbereiche keinen Platz auf der Festplatte reservieren muss, braucht die Datei weniger Platz auf der Festplatte als sie eigentlich groß ist. TreeSize behandelt diese Art von Dateien ähnlich wie komprimierte Dateien und berechnet für sie ebenfalls den Kompressionsfaktor.

Reparse Punkte: Mountpoints und symbolische Links
Seit Windows 2000 unterstützt NTFS Mountpoints und symbolische Links. Ein Mountpoint ist ein existierender Pfad, in den ein anderes Laufwerk "eingehängt" werden kann. Unterhalb dieses Mountpoints findet man dann die komplette Verzeichnisstruktur des eingehängten Laufwerks, ein Buchstabe muss dem eingehängten Laufwerk dabei nicht zugeordnet sein. Auf diese Weise lassen sich viele Laufwerke in einem einheitlichen Dateisystembaum zusammenführen. Symbolische Links funktionieren ähnlich: Hat man beispielsweise ein leeres Verzeichnis C:\Dokumente\Bilder, kann man hier einen symbolischen Link zu E:\Pics erstellen. Anwendungen werden dann den Inhalt von E:\Pics unter C:\Dokumente\Bilder sehen.

Wenn die Einstellung "Mountpoints und symbolischen Links folgen" aktiviert ist, berücksichtigt TreeSize den Inhalt dieser Ordner beim Untersuchen von Laufwerken. Da diese aber nicht physisch auf dem untersuchten Laufwerk liegen, kann dies zu irritierenden Ergebnissen führen.

Eine abschließende Bemerkung: Wenn Sie ein NTFS Laufwerk über das Netzwerk untersuchen, kann TreeSize dateibasierte Kompression und Reparse Punkte nur dann handhaben, wenn es unter Windows NT oder seinen Nachfolgern läuft. Das API von Windows 9x kann diese Eigenschaften nicht handhaben, so dass Reparse Punkte und komprimierte Dateien wie normale Dateien erscheinen.

.topic 20
Allgemein / Registrierung

Hauptprogramm

Drucken / Export

Dateisuche

.topic 21
F:	Wie kann ich TreeSize Professional 3 kaufen und wie wird es geliefert?
A:	Sie können TreeSize Professional 3 Online unter http://www.jam-software.de/prices.shtml bestellen. Dort finden Sie ebenfalls ein Fax-Bestellformular. Die Bestellungen werden von unserer Bestellabteilung spätestens am nächsten Werktag bearbeitet. Für Firmen ist auch der Kauf auf Rechnung möglich. Wenn Sie den Download für den Bezug der Vollversion auswählen, erhalten Sie die Adresse einer geheimen Webseite, von der Sie die Vollversion herunterladen können. Möchten Sie die Software auf Disk mit gedruckten Handbuch geliefert bekommen, fallen zusätzlich noch 6€ Versandkosten an. Außerdem erhalten Sie noch ein Passwort, der für die Installation benötigt wird.

F: Was ist der Unterschied zwischen der Demoversion und der Vollversion?
A:	Die Demoversion erlaubt es Ihnen, unsere Software vor dem Kauf für einen bestimmten Zeitraum zu testen. Die Testphase darf maximal 21 Tage betragen. Darüber hinaus gehende Benutzung der Software ist illegal und verstößt gegen geltendes Recht. Damit unsere Kunden die von uns angebotenen Softwareprodukte in vollem Umfang testen können, enthalten die Demoversionen in der Regel keine signifikanten Einschränkungen. Aber die Software wird sie während der Testphase gelegentlich an den noch nicht vollzogenen Kauf erinnern.

F:	Ich habe Ihr Produkt gekauft. Wie kann ich meine Demoversion jetzt freischalten?
A:	Sie müssen sich die Vollversion in unserem Kundenbereich http://www.jam-software.de/customers/ herunterladen. Die Zugangsdaten haben Sie per E-Mail oder auf dem Lizenzschreiben erhalten. Falls Sie die Zugangsdaten nicht mehr haben, können Sie sich diese noch einmal an die E-Mail Adresse schicken lassen, die Sie beim Kauf verwendet haben.

F: Sind Updates kostenpflichtig?
A:	Updates innerhalb einer Major Version (z.B. 3.x) sind kostenlos. Registrierte Kunden  können das Update auf die nächsthöhere MAjor Version zu einem reduzierten Preis (ca. 40% des normalen Preises) auf der Web-Seite für registrierte Kunden erwerben: http://www.jam-software.de/customers/

F:	Obwohl ich die Vollversion von TreeSize Professional 3 gekauft habe, wird immer noch "Unregistriert" im Fenstertitel angezeigt. Woran könnte das liegen?
A:	Es gibt drei verschiedene Möglichkeiten, warum noch immer "UNREGISTRIERT" im Titel des Fensters erscheint:
1.	Sie haben nicht die Vollversion der Software von der Adresse heruntergeladen, die Sie nach dem Kauf erhalten haben.
2.	Sie haben versehentlich noch einmal die Demoversion installiert. (Wurden Sie nach einem Passwort gefragt?)
3.	Sie haben die Demo- und die Vollversion in verschiedene Verzeichnisse installiert, so dass sich jetzt beide Versionen auf Ihrer Festplatte befinden.

F:	Warum verwenden Sie keine Aktivierungscodes, mit der man eine Demo- in einer Vollversion umwandeln kann?
A:	Wir verwenden keine Aktivierungscodes, da man diese gewöhnlich sehr einfach im Internet finden kann. Wir arbeiten mit unterschiedlichen Test- und Vollversion. Nach dem Kauf erhalten unsere Kunden eine Diskette oder eine Download Adresse, unter der sie sich die Vollversion herunterladen können. Außerdem erhalten Sie ein Passwort, das für die Installation benötigt wird. Beides sollte an einem sicheren Platz aufbewahrt werden.

F:	Gibt es die Möglichkeit einer "Silent" Installation?
A:	Wenn Sie die Installationsdatei mit den Kommandozeilen Parametern /SILENT und /PASSWORD=InstallPasswort aufrufen, wird die Software ohne irgendwelche Nachfragen mit den Default-Werten installiert. Ersetzen Sie bitte InstallPasswort mit dem Passwort, dass Ihnen bei der Registrierung mitgeteilt worden ist. Die Verwendung von /VERYSILENT anstatt von /SILENT blendet auch jegliches visuelles Feedback aus. Die Option /DIR="x:\dirname" kann verwendet werden, um ein alternatives Zielverzeichnis anzugeben.

.topic 22
F:	Warum ist der belegte Platz, den Windows in den Eigenschaften des Laufwerks anzeigt, größer als der von TreeSize Professional 3 angezeigte?
A:	Der Windows Explorer zeigt den physisch auf dem Laufwerk belegten Platz an während TreeSize den Platz anzeigt, den alle Dateien und Verzeichnisse zusammen unterhalb eines bestimmten Pfades belegen. Über den Platz für Dateien und Verzeichnisse hinaus wird auf einem Laufwerk noch zusätzlicher Platz zum Ablegen von Verwaltungsinformationen benötigt, wie z.B. die Dateibelegungstabelle (FAT) oder der Boot Sektor. Hierfür werden üblicherweise rund 0,5 - 2% des Platzes einer Partition benötigt.
    Eine andere Möglichkeit für die Abweichung kann die Verwendung von Software RAID sein, wie es beispielsweise Windows NT/2000 bietet. RAID verteilt die Daten auf mehrere Festplatten, die im System aber wie ein einzelnes Laufwerk erscheinen. Häufig werden die Daten redundant gespeichert, so dass der Ausfall einer einzelnen Festplatte zu keinem Datenverlust führt. Allerdings benötigt das Speichern der redundanten Informationen zusätzlichen Platz auf den Festplatten.
    Eine weitere Möglichkeit für die Abweichung besteht dann, wenn ein Netzwerklaufwerk lediglich mit einem Unterverzeichnis eines Serverlaufwerks verbunden ist. Der von TreeSize angezeigte belegte Platz kann dann niedriger sein als der physisch auf dem Laufwerk belegte Platz, da TreeSize lediglich den über das Netzlaufwerk zur Verfügung gestellten Teilbereich des Laufwerks untersuchen kann.
    Durch fehlende Leserechte kann es ebenfalls dazu kommen, dass TreeSize bestimme Bereiche der Festplatte nicht lesen kann, so dass deren Größe am Ende in der Summe fehlt.

F:	Warum zeigt TreeSize für einige Verzeichnisse ein Datum in der Zukunft an?
A:	Das Datum der letzten Änderung und des letzten Zugriffs, das TreeSize Professional 3 für einen Ordner anzeigt, ist das "späteste" Datum aller Dateien in diesem Ordner und seinen Unterordnern. Wahrscheinlich gibt es also innerhalb des betroffenen Verzeichniszweiges eine oder mehre Dateien mit einem Datum in der Zukunft. Diese sind häufig durch Jahr-2000 Tests oder durch Client PCs mit einem falschen Systemdatum entstanden. Der Windows Explorer berücksichtigt beim Berechnen des Datums des letzten Zugriffs nur die Dateien, die sich unmittelbar in diesem Ordner befinden. Wird also ein Unterordner geändert, so führt dies (unkorrekterweise) nicht zu einer Änderung des Datums des übergeordneten Verzeichnisses.

F:	Warum haben alle Dateien auf meiner Festplatte das gleiche Datum für den letzten Zugriff?
A:	Windows aktualisiert das Datum des letzten Zugriffs jedes Mal, wenn eine Anwendung (lesend) auf eine Datei zugreift. Viele Backup-Programme und Viren-Scanner greifen regelmäßig oder täglich auf viele oder alle Teile der Festplatte zu und verändern so das Datum des letzten Zugriffs.

F:	Warum bezieht TreeSize Professional 3 nicht das Laufwerk in seine Berechnungen mit ein, das ich über die Datenträgerverwaltung von Windows 2000/XP in einem NTFS-Ordner bereitgestellt habe?
A:	Durch Einschalten der Option "Mountpoints und symbolischen Links folgen" in den Einstellungen von TreeSize Professional 3 können Sie festlegen, ob Mountpoints und symbolischen Links gefolgt werden soll oder diese nicht in die Berechnungen einfließen sollen.

F:	Das Untersuchen von Serverlaufwerken über das Netzwerk ist sehr langsam. Kann man dies beschleunigen?
A:	Das Untersuchen von Laufwerken über das Netzwerk ist normalerweise wesentlich langsamer als bei lokalen Laufwerken, da bei Zugriffen über das Netzwerk die Bandbreite geringer und der Overhead höher ist. Serverlaufwerke sind außerdem meist wesentlich größer und enthalten mehr Dateien. Sie können die Scans aber z.B. auf dem Server selbst durchführen oder mit Hilfe der Kommandozeilen Parameter nächtliche Untersuchungen durchführen.

F:	Kann TreeSize Professional 3 die Anzeige von Verzeichnissen unterdrücken, die eine bestimmte Größe unterschreiten?
A:	Im Kontextmenü des obersten Ordners gibt es eine Funktion, mit der alle Ordner aus der Anzeige entfernen werden können, die eine bestimmte Größe unterschreiten. Zur Verwendung klicken Sie bitte mit der rechten Maustaste auf das Wurzelverzeichnis (oder verwenden Sie das Untermenü "Zweig" aus dem Hauptmenü "Datei"), wählen dann "Einblenden" und dann "Entferne Ordner <XX MB".

F:	Kann auch der Freie Platz eines Laufwerks im Tortendiagramm angezeigt werden?
A:	Wenn die Wurzel des untersuchten Laufwerks ausgewählt ist, wird auch der freie Platz des Laufwerks im Tortendiagramm angezeigt, sofern die entsprechende Option im Kontextmenü des Tortendiagramms aktivert ist.

F:	Kann ich ein Netzwerklaufwerk auch untersuchen, ohne es mit einem Laufwerksbuchstaben zu verbinden?
A:	Ja. Sie können UNC Namen der Art \\SERVERNAME\Share verwenden, um Netzwerklaufwerke anzusprechen. Geben Sie diese einfach in der Dropdown Box in der Symbolleiste von TreeSize ein. Sie können UNC Namen auch als Kommandozeilen Parameter verwenden.

F:	Ich würde gerne jedes mal eine bestimmte Menge von Laufwerken untersuchen, wenn TreeSize startet. Ist das möglich?
A:	Sie können einfach eine Verknüpfung zu Tsizepro.exe auf Ihrem Desktop oder im Start-Menü erstellen und die Laufwerke durch Leerzeichen getrennt zur Kommandozeile hinzufügen. Bitte beachten Sie auch das Kapitel "Kommandozeilen Parameter" für weitergehende Informationen.

F: Wie kann ich einen Scan auf nur einen betimmten Benutzer einschränken?
A:	Zuerst versichern Sie sich bitte, dass die Option "Gruppieren nach Benutzern" in den Optinen von TreeSize Professional 3. Nachdem der Scan beendet ist, klicken Sie bitte auf dem Reiter "Benutzer" mit der rechten Maustaste auf den betreffenden Benutzer und wählen dort "Auf diesen Benutzer einschränken" aus.

F:	Warum werden auf einem Novell Netware Laufwerk komprimierte Dateien als unkomprimierte angezeigt?
A:	Prinzipiell können Sie auch Novell Laufwerke unterscuhen, die als Netzwerklaufwerk unter Windows Freigabe erreichbar  sind. Leider liefert der Netware Client für Windows keine Informationen über Kompression und Besitzer durch die normalen Windows API-Funktionen. Daher müssen Entwickler für Netware zusätzlich spezielle Unterstützung einbauen. Wir werden diese in einer späteren Funktion von TreeSize Professional 3 nachliefern. Alle anderen Funktionen stehen jedoch auch auf Netware-Laufwerken uneingeschränkt zur Verfügung.

F:	Beim Untersuchen eines Laufwerks, das Macintosh Dateien enthält, erhalte ich seltsame Fehlermeldungen. Warum?
A:	Unter MacOS dürfen Datei- und Verzeichnisnamen Zeichen enthalten, die unter Windows unzulässig sind (z.B. /, |, <, >, ?) oder die im normalen Windows Zeichensatz nicht enthalten sind. Auf diese Dateien können normale Windows Anwendungen nicht zugreifen, TreeSize verwendet in diesem Fall den 8+3 DOS Namen der Datei oder des Verzeichnisses. Die Anzeige von Fehlermeldungen dieser Art können im Optionen-Dialog abgeschaltet werden.

F:	Warum bezieht TreeSize Professional 3 nicht das Laufwerk mit in seine Berechnungen ein, das mit der Datenträgerverwaltung von Windows auf ein bestimmtes Verzeichnis abgebildet wurde?
A:	Durch Umschalten der Option "Mountpoints und symbolischen Links folgen" in den Optionen kann festgelegt werden, ob TreeSize Professional 3 Mount-Punkten und symbolischen Links folgt oder diese nicht in die Berechnungen einbezieht.

F:	Ist es mit TreeSize Professional 3 möglich, nach Dateiendungen zu suchen?
A:	Sie können beispielsweise in den Optionen einen Filter für einen Scan-Vorgang definieren, indem Sie Suchmuster der Art *.BMP zum Textfeld hinzufügen. Eine zweite Möglichkeit besteht darin, die Funktion "Gruppieren nach Dateitypen" in den Optionen zu aktivieren. Diese wird eine detaillierte Statistik für die Dateitypen in jedem Verzeichnis erstellen und sie werden die Möglichkeit haben, die Anzeige der Verzeichnisgrößen im Baum auf eine bestimmte Dateiendung einzuschränken. Eine dritte Möglichkeit besteht in der Verwendung der Dateisuche für temporäre Dateien, indem eigene Suchmuster auf dem Reiter "Temporäre Dateien" hinzugefügt werden. Unser neues Produkt SpaceObServer verfügt noch über weiter gehende und flexiblere Reportfunktionen.

F:	Der verschwendete Platz, der von TreeSize angezeigt wird, ist bei mir extrem hoch. Wie kann ich diesen reduzieren?
A:	Wahrscheinlich verwenden Sie das FAT Dateisystem, das durch seine großen Blöcke meist eine große Menge an verschwendetem Platz verursacht. Bitte lesen Sie das Kapitel "Verschwendeter Platz" um zu verstehen, was verschwendeter Platz ist und wie man ihn reduzieren kann.

.topic 23
F:	Ich würde gerne eine komplette Liste all meiner Dateien auf der Festplatte drucken. Warum unterstützt TreeSize Professional 3 dies nicht?
A:	Eine normale Windows 2000 Installation umfasst alleine schon 6000 bis 10000 Dateien im Windows Verzeichnis. Das Ausdrucken dieses Verzeichnisbaumes würde schon 90 - 130 Blatt Papier erfordern, für die gesamte Festplatte wäre noch wesentlich mehr erforderlich. Deshalb unterstützt TreeSize nur das Drucken des Inhalts des selektierten Verzeichnisses. Darüberhinaus kann aber eine komplette Liste aller Dateien im untersuchten Verzeichniszweig in die Zwischenablage kopiert werden. Diese kann dann in einer Tabellenkalkulation oder einer Datenbank weiterverarbeitet oder gedruckt werden.

Q:	Wie kann ich die Spalten auswählen, die in einem gedruckten Report oder einer exportierten Excel-Datei erscheinen?
A:	Unter Ansicht / Optionen / Spalten können die gewünschten Spalten ausgewählt werden, nachdem Sie in der Dropdown Box am oberen Rand ein Export-Medium ausgewählt haben.

.topic 24
F:	Wie kann ich nach Dateien vom Typ XYZ suchen?
A:	Die Windows Dateisuche erfüllt diese Aufgabe bereits relativ gut. TreeSize Professional 3 wurde primär zum Auffinden alter und überflüssiger Dateien konzipiert, dennoch gibt es natürlich Möglichkeiten bestimmte Dateitypen zu finden. Sie können beispielsweise nur die Suche nach Temporären Dateien aktivieren, dort deaktivieren Sie alle Suchmuster und fügen das gewünschte hinzu. Weitere Möglichkeit:  Im Hauptprogramm setzen Sie in den Optionen einen Filter. Der sorgt dafür, dass beim Bestimmen der Verzeichnisgrößen nur zum Filter passende Dateien berücksichtigt werden. Das Ergebnis verschafft einen recht guten Überblick über die Verteilung dieses Dateityps. Unser Produkt SpaceObServer, das die Daten über die beobachteten Dateisysteme in einer SQL-Datenbank speichert, hat darüber hinaus noch schnellere und flexiblere Reporting Funktionen.

F:	Warum enthält TreeSize Professional 3 keine Suche für doppelte Dateien?
A:	Wir haben mehrere Tests mit existierenden Tools zur Suche nach doppelten Dateien durchgeführt. Die Menge an Festplattenplatz, die zurückgewonnen werden konnte, war jeweils extrem gering, da nur wenige der angezeigten Dateien echte doppelte Dateien waren, die problemlos gelöscht werden konnten. Der Zeitaufwand, der zur Durcharbeitung der Liste benötigt wurde, war sehr groß. Und die Gefahr, das ein unerfahrener Benutzer in Unkenntnis eine notwendige Datei löscht, war ebenfalls groß.

F:	Ist es möglich gleichzeitig mehrere oder alle Dateien in den Ergebnislisten der Dateisuche zu markieren?
A:	Es können wie in anderen Anwendungen üblich mehre Einträge mit der linken Maustaste ausgewählt werden, wenn gleichzeitig die Strg- oder Umschalttaste gleichzeitig gedrückt wird. Durch Drücken von Strg+A werden alle Einträge der Liste markiert. Nun können mit dem Menüpunkt "Markieren" aus dem Kontextmenü alle ausgewählten Dateien markiert werden. Aufeinander folgende Einträge können übrigens auch durch mehrmaliges Drücken der Leertaste markiert werden.

.topic 7
Der Optionen Dialog wird durch den entsprechenden Menüpunkt im "Ansicht"-Menü oder über die Symbolleiste aktiviert. Er erlaubt die Festlegung von Einstellungen für die Darstellung und den Untersuchungsvorgang (Scan) und besteht aus folgenden Reitern:

Ansicht
Untersuchen
Filtern
Spalten

.topic 71
Andere Farbe für komprimierte Dateien und Ordner	Ist diese Option aktiviert, werden komprimierte Dateien auf einem NTFS Laufwerk in blauer Farbe angezeigt. Verzeichnisse, die nur teilweise komprimiert sind, werden dunkelblau angezeigt, Dateien und Verzeichnisse, die komplett komprimiert sind, erscheinen hellblau. Für weitere Informationen über dateibasierte Komprimierung lesen Sie bitte das Kapitel "Hinweise zu NTFS".

Zeige Dateien	Wenn diese Option ausgewählt ist, werden die Dateien eines Ordners in der Verzeichnisstruktur summiert in einem Objekt angezeigt. Außerdem werden die Dateien in der Detaildarstellung einzeln angezeigt.

Symbolleiste für Diagramme	Zeigt eine zusätzliche Symbolleiste zur Manipulation der Diagramme an.

Rechte Seite während des Scannens aktualisieren	Ist diese Option aktiviert, so aktualisiert TreeSize Pro die rechte Seite des Fensters von Zeit zu Zeit. Dies erlaubt es z.B. die Balkendiagramme während des Scans wachsen zu sehen. Verwenden Sie den Schieber um das Intervall einzustellen.

Dezimalstellen	Anzahl der Dezimalstellen, die TreeSize bei der Darstellung von Werten nach dem Dezimalpunkt verwenden soll.

Einträge in Liste zuletzt untersuchter Dateien	Im Datei-Menü und in der Box zum Auswählen der Laufwerke finden Sie eine Liste mit den zuletzt untersuchten Ordnern und Laufwerken. Hier können Sie einstellen, wie viele Einträge diese Liste maximal haben soll.

Fettdruck Faktor	Wenn die Größe eines Verzeichnisses größer als der angegebene Wert oder Prozentsatz des gesamten untersuchten Verzeichnisses ist, dann wird der Verzeichnisname in Fettschrift dargestellt. Dies ermöglicht es Ihnen schnell die besonders großen Verzeichnisse zu erkennen. Wenn Sie keine fett gedruckten Verzeichnisnamen wünschen, wählen Sie hier 100% aus. Sie können diese Einstellung auch für den Report-Druck verwenden, indem Sie die darunter liegende Checkbox aktivieren.

.topic 72
Wenn Sie Veränderungen auf der Seite 'Untersuchen' vornehmen, ist ein erneutes Einlesen aller aufgeführten Verzeichnisse und Laufwerke erforderlich. Diese Einstellungen werden beim Beenden von TreeSize Professional nicht gespeichert, um falsche Ergebnisse bei der nächsten Benutzung zu vermeiden. Es stehen folgende Einstellungen zur Auswahl:

Mountpoints und symbolischen Links folgen	Diese Option wirkt sich nur auf NTFS Laufwerken aus und entscheidet darüber, ob TreeSize Pro Mountpoints und symbolischen Links folgen soll oder nicht. Weitere Informationen hierzu gibt es im Kapitel "Hinweise zu NTFS".

Zeige Fehlermeldungen	Hier können Sie festlegen, ob TreeSize Professional Fehlermeldungen während der Untersuchung eines Ordners oder Laufwerks anzeigen soll (und dabei anhalten soll) oder nicht. Wenn Sie beispielsweise ein Netzwerklaufwerk auf einem NT Server untersuchen, auf dem Sie für einige Verzeichnisse keine Leserechte besitzen, wird jeweils eine Fehlermeldung angezeigt. Wenn die Untersuchung nicht durch diese Meldungen unterbrochen werden soll, deaktivieren Sie diese Option.

Gruppieren nach Benutzernamen	Ist diese Option aktivert, wird Benutzernamenalle Daten eines Verzeichnisses nach Benutzernamen gruppieren. Die Ergebnisse können auf dem Reiter "Benutzer" betrachtet werden. Diese Option verschafft Ihnen einen guten Überblick darüber, welcher User in welchem Verzeichnis wie viel Platz belegt. Da für jede Datei beim System der Besitzer erfragt werden muss, verlangsamt das Einschalten dieser Funktion einen Scan signifikant.

Gruppieren nach Dateiendungen	Ist diese Option aktiviert, so werden die gesammelten Daten pro Verzeichnis zusätzlich nach der Dateiendung gruppiert. Die Ergebnisse können auf dem Reiter "Dateitypen" betrachtet werden.

Benutzerdefinierte Blockgröße	Verwenden Sie diese Einstellung, um sich ein Bild davon zu machen, wie Ihr Laufwerk mit einer anderen Blockgröße aussehen würde. Die Blockgröße hat Einfluss auf den belegten und den verschwendeten Platz Ihrer Verzeichnisse. Diese Option speichert TreeSize Professional 3 nach dem Beenden nicht ab, um bei der nächsten Benutzung falsche Ergebnisse zu vermeiden.

.topic 73
Der Reiter "Filtern" erlaubt, bestimmte Dateien für die Scans ein- oder auszuschließen.

Dateitypen	Wenn Sie nur Informationen über bestimmte Dateitypen haben wollen, können Sie hier einen Filter angeben. Es können auch mehrere Filter durch Leerzeichen getrennt angegeben werden. Wenn Sie beispielsweise nur Informationen über Programmdateien haben wollen, geben Sie hier "*.exe *.dll" an. Wenn Sie alle Dateien mit einbeziehen möchten, geben Sie einfach "*" an. Diese Option speichert TreeSize Professional 3 nach dem Beenden nicht ab, um bei der nächsten Benutzung falsche Ergebnisse zu vermeiden. Wenn sie öfter einen Scan für nur bestimmte Dateitypen durchführen, können Sie hierfür eine eigene Verknüpfung erzeugen für diese entsprechende Kommandozeilen Parameter festlegen.

Nur Dateien mit Erstellungsdatum innerhalb XX Tage	 Diese Option bezieht nur Dateien mit in einen Scan ein, die innerhalb der angegebenen Anzahl von Tagen neu erstellt worden sind. Mit dieser Option können Sie sich einen guten Überblick über stark wachsende Verzeichnisse verschaffen.

Nur Dateien mit gesetztem Archiv-Attribut einbeziehen	Diese Option ist nützlich, wenn Sie wissen wollen, wie groß Backups für ein bestimmtes Verzeichnis werden.

Ausschlusskriterien	Wenn bestimmte Dateien oder Verzeichnisse vom Scan ausgeschlossen werden sollen, können Sie hier ein entsprechendes Muster der Art "Windows" oder "*.tmp"  hinzufügen. Alle Dateien und Verzeichnisse, die auf eines der angegebenen Muster passen, werden dann nicht in den Scan einbezogen.

.topic 74
Auf der Seite 'Spalten / Export' können Sie auswählen, welche Spalten sichtbar sein sollen. Dies kann separat für jedes "Ausgabe-Medium" (Detailansicht, Excel Export, Gedruckter Report, Textdatei etc.) festgelegt werden , in dem der entsprechende Eintrag in der Auswahlbox im oberen Bereich ausgewählt wird. Die folgenden Spalten stehen zur Verfügung:

Name	Der Name der Datei oder des Ordners

Absoluter Pfad	Der absolute Pfad inklusive des Namens des Objekts.

Größe	Die Größe des Objekts.

Belegt	Der Platz, den das Objekt aktuell auf der Platte belegt (siehe auch: Verschwendeter Platz).

Dateien	Die Anzahl der Dateien in einem Ordner.

Ordner	Die Anzahl der Unterordner in einem Ordner.

Verschwendet	Der Platz, der durch das Dateisystem verschwendet wird (siehe auch: Verschwendeter Platz).

Prozent	Der Platz, den ein Objekt relativ zu dem Ordner belegt, in dem es gespeichert ist.

Letzte Änderung	Das Datum der letzten Änderung eines Objekts. TreeSize Professional 3 berechnet das Datum der letzten Änderung und des letzten Zugriffs für Ordner exakter als dies der Windows Explorer tut. Daher können sich die angezeigten Werte von denen des Windows Explorer unterscheiden.

Letzter Zugriff	Das Datum, an dem zuletzt auf ein Objekt zugegriffen worden ist.

Kompr.	Die Größe in Prozent, um die das Objekt durch die eingebaute Kompression des Dateisystems komprimiert werden konnte. (siehe auch: Hinweise zu NTFS).

Besitzer	Der Name des Benutzers, der für das Objekt als Besitzer eingetragen ist.

CD-ROM Größe	Der Platz, den das Objekt auf einer CD-ROM belegen würde.

Aktuelles Datum	Das aktuelle Datum. Diese Spalte kann nützlich sein, wenn die gesammelten automatisiert weiter verarbeitet werden sollen, z.B. in einer Datenbank.

Attribute	Die Datei-Attribute Schreibgeschützt (R), Versteckt (H), System (S), Archiv (A).

Dateityp	Der Typ des Objekts, z.B. "Textdatei".

Verzeichnistiefe	Die Ebene, auf der sich das Objekt im Dateisystem Baum befindet. Diese Spalte kann nützlich sein, wenn die gesammelten automatisiert weiter verarbeitet werden sollen, z.B. in einer Datenbank.

Erstellungsdatum	 Das Datum, an dem das Objekt erstellt worden ist.

Pfad (ohne Dateiname)	Der absolute Pfad des Verzeichnisses, in dem sich das Objekt befindet.

Durchschn. Dateigröße	Die durchschnittliche Größe der Dateien in einem Ordner.

Berechtigungen	Die Zugriffsberechtigungen für das Objekt in dem Format: Benutzername1: +/-R +/-W +/-X   Benutzername2: ... wobei ein gewährtes Recht mit "+" und ein verwehrtes Recht mit "-" gekennzeichnet wird.

Dateiversion	Die Versionsnummer die in EXE, DLL, OCX und ähnlichen, binären Dateien meist enthalten ist.

Titel des Scans	Standardmäßig der Titel eines Scans. Er kann mit Hilfe von "Titel angeben" im Datei Menü geändert werden. Dies kann beispielsweise bei der Archivierung der gesammelten Daten nützlich sein.

Die angezeigten Spalten in der Detail-Liste von TreeSize Professional 3 können schnell über das Kontextmenü des Listenkopfes ausgewählt werden:

Export

Kompletter Baum	Der komplette Dateisystembaum wird exportiert.

Nur aufgeklappte Ordner	Es werden nur die im linken Teil des Fensters aufgeklappten Teile des Dateisystembaums exportiert.

Kopfzeile	Mit dieser Option können Sie steuern, ob beim Export eine Kopfzeile mit den Namen der Spalten erzeugt werden soll.

Standard-Exportdatei	Hier können Sie einstellen, in welche Excel-Datei standardmäßig die Daten geschrieben werden sollen.

.topic 61
Das Datei Menü erlaubt Ihnen Verzeichnisse zum Untersuchen auszusuchen, untersuchte Verzeichnisse aus dem Fenster zu entfernen und die gesammelten Daten zu exportieren oder zu drucken:

Verzeichnis auswählen	Zeigt einen Dialog zum Auswählen eines Verzeichnisses an.

XML-Report öffnen	Öffnet eine XML-Datei, der durch TreeSize Professional 3 zuvor gespeichert worden ist. Auf diese Weise können Sie frühere Scan-Ergebnisse betrachten, ohne einen neuen Scan durchführen zu müssen.

Als XML-Report speichern	Speichert die gesammelten Daten des aktuellen Verzeichniszweiges in eine XML-Datei, die später wieder mit TreeSize Professional 3 geöffnet werden oder zu Vergleichszwecken genutzt werden kann.  TreeSize Professional 3 wird mit einer XSLT-Datei ausgeliefert, die die Daten ein solchen XML Datei für die Darstellung in XSLT-fähigen Browser konvertiert  (z.B. Firefox >V1.0 oder Internet Explorer >V5.5).

Mit XML-Report vergleichen	Lädt eine gespeicherte XML-Datei und vergleicht sie mit den aktuellen Daten durch Differenzbildung der alten Daten mit den aktuellen.  Nach der Differenzbildung haben unverändert große Verzeichnisse die Größe 0. Gewachsene Verzeichnisse eine positive Größe und werden in roter Farbe dargestellt. In der Größe reduzierte Verzeichnise haben negative Werte und werden in grüner Farbe dargestellt.

Export	Siehe Kapitel Export

Titel angeben	Hier können Sie einen Titel für den gerade aktiven Verzeichniszweig angeben. Dieser Titel wird beim Exportieren oder Drucken des Verzeichniszweigs verwendet. Standardmäßig besteht der Titel aus dem Pfad des untersuchten Ordners und dem Namen des Laufwerks.

Drucke Bericht	Druckt einen detaillierten Bericht für das aktive Verzeichnis (siehe unter Drucken).

Bericht für alle Drucken 	Druckt einen Bericht für alle untersuchten Laufwerke und Ordner im linken Bereich des Fensters.

Drucke Diagramm 	Druckt das gerade angezeigte Diagramm (siehe unter Diagramme).

Drucke Ordnerinhalt	Druckt eine Liste aller Objekte im gerade ausgewählten Ordner, mit Größe, Datum, etc.

Seite einrichten	Zeigt den Dialog zum Einrichten der Seite an, in dem Sie Papiergröße und Ränder für den Druck einstellen können.

Drucker einrichten	Zeigt den Dialog zum Auswählen und Einrichten des Druckers.

Beenden	Schließt die Anwendung.

.topic 62
Das Untermenü "Export" erlaubt den Export gesammelter Daten auf verschiedenen Wegen. Die Art der Daten (Spalten), die exportiert werden sollen, können auf dem Reiter "Spalten" in den Einstellungen festgelegt werden. Für alle Wege des Exports gilt, dass nur die Daten solcher Verzeichnisse exportiert werden, die im linken Teil des Hauptfensters sichtbar (expandiert) sind. So können Sie die Menge der exportierten Daten entweder manuell, oder mit Hilfe des Kontextmenüs kontrollieren. Diese Einstellung kann ebenfalls in den Optionen verändert werden.

Speichern unter	Speichert die gesammelten Daten in eine Textdatei (durch Tabulatoren getrennt). Es werden wiederum nur die Verzeichnisse exportiert, die im Verzeichnisbaum auch eingeblendet sind. Wählen Sie 'Alles einblenden' aus dem Kontextmenü um eine komplette Liste zu erhalten.

Speichern als HTML	Speichert die Ergebnisse in eine HTML Datei, die dann mit jedem Browser angeschaut werden kann. Es werden nur die Ergebnisse der Dateien exportiert, die im Verzeichnisbaum auch eingeblendet sind. Wird gerade ein Diagramm angezeigt, so wird dieses in den oberen Bereich der HTML-Datei eingebettet.

Exportieren nach Excel	Exportiert die gesammelten Daten nach MS Excel. Es werden wiederum nur die Verzeichnisse exportiert, die im Verzeichnisbaum auch eingeblendet sind. Wählen Sie 'Alles einblenden' aus dem Kontextmenü um eine komplette Liste zu erhalten.

Kopiere gesammelte Daten	Kopiert die gesammelten Daten in die Zwischenablage. Es werden nur die Verzeichnisse exportiert, die im Verzeichnisbaum auch eingeblendet sind. Wählen Sie 'Alles einblenden' aus dem Kontextmenü um eine komplette Liste zu erhalten.

Als E-Mail senden	Sendet die aktuellen Daten als E-Mail über die MAPI-Schnittstelle von Windows.

Rohdaten verwenden	Das Aktivieren dieser Option bewirkt, dass Daten nicht formatiert (z.B. 10,2 MB) sondern als reine Zahlen gespeichert werden (z.B. 10695475). Dies kann die Nachbearbeitung der Daten vereinfachen.

Einstellen	Öffnet den Optionen Dialog, mit dem die Spalten für den Export ausgewählt werden können.

Kopiere Dateiliste	Kopiert eine komplette Liste aller Dateien in dem untersuchten Ordner (und allen Unterordnern) in die Zwischenablage. Sie können diese Liste in Ihre Tabellenkalkulation einfügen oder mit einer Datenbank weiterverarbeiten.

.topic 63
Sie können verschiedene Arten von Ansichten innerhalb von TreeSize Professional wählen:

Größe	Zeigt die Größe eines Ordners inklusive aller Unterordner an.

Belegter Platz	Zeigt an, wie viel Platz der Ordner tatsächlich auf dem Laufwerk belegt.

Prozent	Zeigt den Anteil jedes Verzeichnisses an seinem übergeordneten Verzeichnis in Prozent an.

Verschwendeter Platz   Zeigt den durch das Dateisystem verschwendeten Platz an, der durch das Speichern dieses Ordners verloren gegangen ist.

CD-ROM Blockgröße   Zeigt an, wie viel Platz ein Ordner auf einer CD-ROM belegen würde.

Mit den darauf folgenden Menüpunkten können Sie auswählen, was in der rechten Hälfte des Fensters von TreeSize Professional angezeigt werden soll:

Balkendiagramm	Zeigt ein Balkendiagramm auf der rechten Seite des Fensters an. Jeder Balken zeigt die Größe und den verschwendeten Platz (die zusammen den belegten Platz bilden) eines Unterverzeichnisses an.

Tortendiagramm	Zeigt ein Tortendiagramm in der rechten Hälfte des Fensters an. Die dargestellten Werte hängen von dem gerade ausgewählten Modus (Größe, belegter Platz, Prozent, etc.) ab.

Details	Zeigt eine Liste aller Objekte im gerade ausgewählten Ordner an. Für jedes Objekt werden zahlreiche Details wie die Größe, der belegte Platz, der verschwendete Platz, die Anzahl der enthaltenen Objekte, der prozentuale Anteil am übergeordneten Ordner und das Datum des letzten Zugriffs und der letzten Änderung angezeigt. Sie können in den Optionen einzelne Spalten ausblenden.

Die Art, in der TreeSize Größenangaben darstellt, können mit den folgenden Menüpunkten oder den entsprechenden Schaltflächen auf der Symbolleiste verändert werden. Die Anzahl der Nachkommastellen kann in den Einstellungen angepasst werden.

Werte als KB	Alle Größenangaben werden in KB angezeigt

Werte als MB	Alle Größenangaben werden in MB angezeigt.

Werte als GB	Alle Größenangaben werden in GB angezeigt.

Gemischte Größenangaben   Auf Basis der Größe des anzuzeigenden Wertes wird automatisch eine passende Einheit ausgewählt.

Weiterhin können Sie im Ansicht Menü das Fenster zur Dateisuche und den Einstellungsdialog einblenden.

Optionen	Zeigt den Dialog mit den Einstellungen von TreeSize Professional an.

.topic 64
Sortieren nach Größe	Hierbei werden die größten Verzeichnisse zuerst aufgelistet

Sortieren nach Name	Hierbei werden die Verzeichnisse in alphabetischer Reihenfolge aufgelistet.

Aus	Es wird keine Sortierung durchgeführt. Dies kann nützlich sein, wenn man sehr große Verzeichnisse untersucht. So kann man sich Teilergebnisse anschauen, ohne dass Verzeichnisse ständig ihre Position wechseln.

.topic 65
Alle aktualisieren	Aktualisiert die Ergebnisse für alle gerade angezeigten Verzeichnisse. Dieser Vorgang kann unter Umständen längere Zeit dauern. Ein einzelnes Verzeichnis können Sie aktualisieren, indem Sie den entsprechenden Menüpunkt aus dem Kontextmenü dieses Ordners auswählen oder F5 drücken.

Dateisuche	Zeigt das Fenster zur Dateisuche an, mit dem Sie nach alten, besonders großen oder überflüssigen temporären Dateien suchen können.

Software Hinzufügen / Entfernen	Öffnet den Dialog aus der Systemsteuerung, mit dem Software hinzugefügt oder entfernt werden kann.

Netzwerklaufwerk verbinden	 Öffnet ein Fenster, das das Verbinden eines Netzwerklaufwerks mit einem Laufwerksbuchstaben erlaubt. Es können aber auch UNC-Pfade der Form \\Host\Share in die Laufwerksbox links oben eingegeben werden.

.topic 69
Dateisystem-Baum
Wenn Sie mit der rechten Maustaste auf ein Verzeichnis klicken, zeigt Ihnen TreeSize Professional das Kontextmenü des Explorer an. Außerdem finden Sie noch folgende Menüpunkte im TreeSize Untermenü:

Alles einblenden	Blendet alle Verzeichnisse unterhalb dieses Ordners ein.

Alles ausblenden	Blendet alle Verzeichnisse unterhalb dieses Ordners aus.

Zweig aktualisieren	Aktualisiert nur die Daten im Verzeichniszweig unterhalb dieses Ordners. Dies ist wesentlich schneller, als das gesamte untersuchte Verzeichnis erneut einzulesen.

Aus TreeSize entfernen (temporär)	Hiermit kann ein Verzeichnis aus dem Baum und aus den Berechnungen von TreeSize entfernt werden, das Verzeichnis wird jedoch nicht physikalisch vom Laufwerk gelöscht und erscheint daher beim nächsten Durchlauf wieder.

Für den obersten Ordner wird ein anderes Kontextmenü mit besonderen Funktionen angezeigt. Es sieht  folgendermaßen aus:

Bis Ebene X	Blendet alle Verzeichnisse unterhalb des aktiven Ordners bis zu einer bestimmten Tiefe (1-4) ein.

Ordner einblenden über	Blendet alle Ordner ein, die größer als die angegebene Größe sind.

Entferne Ordner <xxx MB	Entfernt alle Ordner aus der Ansicht, die kleiner als die angegebene Größe sind.

Größe festlegen	Legt die Grenzgröße für die beiden vorangegangenen Operationen fest.

Aus TreeSize entfernen	Entfernt den Order aus dem Fenster von TreeSize Professional.

Aktualisieren	Liest diesen Verzeichniszweig erneut ein.

Details-Liste
The Details-Liste zeigt bei einem Rechts-Klick auf ein Objekt das Kontextmenü des Windows Explorer an. Zusätzlich existiert ein Untermenü mit dem Namen "TREESIZE" das alle verfügbaren Information des ausgewählten Objekts anzeigt. Darin eingeschlossen sind auch die Spalten, die momentan nicht aktiviert sind. Dieses Untermenü kann uaßerdem dazu verwendet werden, um Spalten zu aktivieren und zu deaktiveren.

.topic 13
Das Fenster zur Dateisuche erlaubt es Ihnen nach alten, besonders großen oder temporären Dateien zu suchen. Es gibt folgende Seiten im Fenster:

Größte Dateien	Diese Seite bietet die Möglichkeit Ihre Festplatten nach besonders großen Dateien zu durchsuchen. Sie müssen eine minimale Größe in Kilobytes oder Megabytes angeben. Alle Dateien, die größer als dieser Wert sind, werden dann in der Liste aufgeführt.

Älteste Dateien	Diese Seite erlaubt es nach Dateien zu suchen, auf die seit einem bestimmten Datum nicht mehr zugegriffen wurde oder die seit einem bestimmten Datum nicht mehr geändert worden sind. Die Suche kann auf komplette Ordner eingeschränkt werden, es werden dann diejenigen Ordner aufgeführt, in denen alle Dateien seit dem angegebenen Datum nicht mehr geändert bzw. geladen worden sind.

Temporäre Dateien	Diese Seite zeigt temporäre Dateien an, die vermutlich nicht mehr benötigt werden. Verwenden Sie die Schaltfläche "Konfigurieren", um die Einstellungen der temporären Dateisuche anzupassen.

Internet Dateien 	Diese Seite zeigt temporäre Internet Dateien an. Dazu gehören zum Beispiel die Seiten und Grafiken im Cache der Browser Netscape Navigator und Internet Explorer. Diese Dateien verursachen auf FAT Laufwerken viel verschwendeten Speicherplatz, da sie meist sehr klein sind.

Optionen	Auf dieser Seite können die Laufwerke ausgewählt werden, auf die sich die Suche erstrecken soll und es können die Such-Arten ausgewählt werden, die durchgeführt werden sollen. Es können zusätzliche Pfade oder Laufwerke mit den Schaltflächen unterhalb der Liste der Laufwerke hinzugefügt werden.

Auf der rechten Seite des Fensters stehen folgende Schaltflächen zur Verfügung:

Start	Diese Schaltfläche startet die Suche. Sie können nach dem Start entweder das Fenster ausblenden und die Ergebnisse später betrachten, oder Sie können sich bereits Teilergebnisse auf den einzelnen Seiten anschauen. Es ertönt ein kurzes akustisches Signal, wenn TreeSize Professional die Suche beendet hat.

Stop	Diese Schaltfläche hält die Suche an.

Fenster ausblenden	Mit dieser Schaltfläche kann das Fenster zur Dateisuche ausgeblendet werden, die Suche wird dadurch nicht unterbrochen. Sie können sich die Suchergebnisse dann später anschauen. Solange die Suche noch läuft, wird unterhalb dieser Schaltfläche eine Animation angezeigt.

Ergebnisse Speichern	Diese Schaltfläche erlaubt es, die Ergebnisse der gerade sichtbaren Suchart abzuspeichern. Die Ergebnisse werden dabei durch Tabulatoren unterteilt in eine Textdatei gesichert.

Markierte Verschieben	Diese Schaltfläche verschiebt oder löscht alle durch einen Haken markierten Dateien auf den einzelnen Seiten. Sie können auswählen, ob die markierten Dateien in den Papierkorb verschoben werden sollen, komplett von der Festplatte gelöscht oder an einen beliebigen Ort im Dateisystem verschoben werden sollen. Wenn Sie die markierten Dateien zu einem bestimmten Pfad im Dateisystem verschieben, bleibt die Verzeichnisstruktur erhalten. Sie können die Dateien dann zum Beispiel in einer ZIP-Datei oder auf CD-R(W) archivieren.
    TIPP: Sie können einfach eine aufeinander folgende Gruppe von Dateien markieren, indem Sie die Leertaste mehrmals hintereinander drücken. Es können auch mehrere Einträge mittels der Shift- und Strg-Tasten ausgewählt und dann durch den Kontextmenüeintrag 'Markieren' markiert werden.

.topic 521
Muster
Der zentrale Teil der temporären Dateisuche basiert auf typischen Mustern von Dateinamen. Diese Muster können konfiguriert werden, nachdem die Schaltfläche "Konfigurieren" im oberen Teil der temporären Dateisuche betätigt worden ist.  Es können dann einzelne Muster editiert, gelöscht oder hinzugefügt werden. Durch die Checkboxen auf der linken Seite können einzelne Muster auch vorübergehend deaktiviert werden.

Dateien mit gesetztem Attribut für "temporär" einbeziehen
Anwendungen, die temporäre Dateien erstellen, können das System über diesem Umstand durch Setzen eines speziellen Attributs informieren. Ist diese Option aktiviert, fügt TreeSize Professional 3 auch diese Dateien der Ergebnisliste hinzu.

Dateien einbeziehen, die zu keinem gültigen Benutzeraccount gehören
Wird ein Benutzerprofil unter Windows gelöscht, werden nicht automatisch alle Dateien gelöscht, die als Besitzer dieses Benutzerpofil haben und belegen so weiterhin Plattenplatz. Durch Aktivierung dieser Option werden solche Dateien der Ergebnisliste hinzugefügt. Da für jede Datei zunächst der zugehörige Besitzer bestimmt werden muss, verlangsamt die Aktivierung dieser Option den Scan-Prozess signifikant.

Verweise ohne gültiges Ziel einbeziehen
Durch Aktivierung dieser Option überprüft TreeSize Professional 3 .LNK und .PIF Dateien daraufhin, ob der zugehörige Zielpfad noch existiert. Ist dies nicht der Fall, so werden die entsprechenden Dateien der Ergebnisliste hinzugefügt.

.topic 4
Vielen Dank für Ihr Interesse an TreeSize Professional. Es gibt folgende Möglichkeiten der Bestellung:

1	Eine Sichere Online Bestellung ist über unsere Internet Seite möglich.

2.	Firmen innerhalb der EU können auch gegen Rechnung bestellen. Eine aktuelle Preisliste für Mehrbenutzer-Lizenzen finden Sie auf unserer Internet Seite. Ihre Bestellung senden oder faxen Sie bitte an:

JAM Software
Joachim Marder
Bruchhausenstr. 1
D-54290 Trier

Fax:     0700-70707059
E-Mail: sales@jam-software.com
WWW: www.jam-software.de

Nach Ihrer Registrierung erhalten Sie die Informationen, wie Sie die Vollversion herunterladen können. Registrierte Benutzer erhalten bei Problemen Hilfe per E-Mail und können zukünftigen Versionen innerhalb einer Hauptversionsnummer wie V3.x ohne zusätzliche Kosten herunterladen.

.topic 3
Copyright Ó1996-2005 by

JAM Software
Joachim Marder
Bruchhausenstr. 1
D-54290 Trier

FAX:	0700-70707059

E-Mail:	treesize@jam-software.com

WWW:	http://www.jam-software.de

.topic 101
Ist diese Option aktiviert, werden komprimierte Dateien auf einem NTFS Laufwerk in blauer Farbe angezeigt. Verzeichnisse, die nur teilweise komprimiert sind, werden dunkelblau angezeigt, Dateien und Verzeichnisse, die komplett komprimiert sind, erscheinen hellblau.

.topic 102
Wenn diese Option ausgewählt ist, werden die Dateien eines Ordners in der Verzeichnisstruktur summiert zu einem Objekt angezeigt. Außerdem werden alle Dateien eines Ordners in der Detail-Liste angezeigt.

.topic 103
Zeigt eine zusätzliche Symbolleiste zur Manipulation der Diagramme an.

.topic 104
Anzahl der Dezimalstellen, die TreeSize bei der Darstellung von Werten nach dem Dezimalpunkt anzeigt.

.topic 105
Wenn die Größe eines Verzeichnisses größer als der angegebene Wert oder Prozentsatz des gesamten untersuchten Verzeichnisses ist, dann wird der Verzeichnisname in Fettschrift dargestellt. Dies ermöglicht es Ihnen schnell die besonders großen Verzeichnisse zu erkennen. Wenn Sie keine fett gedruckten Verzeichnisnamen wünschen, wählen Sie hier 100% aus.

.topic 106
Im Datei-Menü und in der Box zum Auswählen der Laufwerke finden Sie eine Liste mit den zuletzt untersuchten Ordnern und Laufwerken. Hier können Sie einstellen, wie viele Einträge diese Liste maximal haben soll.

.topic 111
Wenn Sie nur Informationen über bestimmte Dateitypen haben wollen, können Sie hier einen Filter angeben. Wenn Sie beispielsweise nur Informationen über Programmdateien haben wollen, geben Sie hier '*.exe *.dll' an. Wenn Sie alle Dateien mit einbeziehen möchten, geben Sie einfach '*' an.

.topic 112
Verwenden Sie diese Einstellung, um sich ein Bild davon zu machen, wie Ihr Laufwerk mit einer anderen Blockgröße aussehen würde. Die Blockgröße hat Einfluss auf den belegten und verschwendeten Platz Ihrer Verzeichnisse.

.topic 113
Hier können Sie bestimmen, ob TreeSize Professional Fehlermeldungen während der Untersuchung eines Ordners/Laufwerks anzeigen soll (und dabei anhalten soll) oder nicht. Wenn Sie beispielsweise ein Netzwerklaufwerk auf einem NT Server untersuchen, auf dem Sie bei einigen Verzeichnissen kein Leserecht haben, wird jeweils eine Fehlermeldung angezeigt. Wenn die Untersuchung nicht durch diese Meldungen unterbrochen werden soll, wählen Sie diese Option nicht aus.

.topic 114
Diese Option wirkt sich nur auf NTFS Laufwerken aus und entscheidet darüber, ob TreeSize Pro Mountpoints und symbolischen Links folgt.

.topic 121
Hier können Sie auswählen, welche Werte in der Detailansicht angezeigt werden sollen.

.topic 142
Hier kann eine Datei angegeben werden, die standardmäßig verwendet werden soll, wenn der Export manuell angestoßen wird. Existiert die Datei bereits, so werden die Daten an die vorhandene Datei angehängt.